iPhone app recording issues

We've seen a recent increase in the number of iOS users reporting GPS issues when recording but we aren't quite sure of the cause. This means the app freezes or stops mid-recording which results in incomplete data and missing portions of your activity. To help us investigate the issue, please try the troubleshooting steps below and let us know if it improves your future recordings:

  • Try turning your phone completely off then on.
  • Try turning location services off then on. Location services are located in settings > privacy > location services (turn off/on).
  • Try turning off wifi before and during recording. 
  • Close all other open applications before recording and if you open another app during your activity, navigate back to Strava afterward.
  • Lastly, sometimes recording data quality can be improved by giving your phone more time to acquire satellites prior to starting your activity. Try opening Strava when you have a clear and unobstructed view of the sky and wait a few more minutes than normal before starting your activity. 

Update: We've received reports that updating to iOS 11.3 has helped to improve GPS recordings on Strava.

Was this article helpful?
94 out of 241 found this helpful
Have more questions? Submit a request

Comments

126 comments
  • I've been having issues as well. Same iPhone, same routes, no significant changes in the way I use Strava or any other app, but now my rides are not accurate. Today my commute was 0 km; nothing was recorded even though I made sure Strava was started with a GPS lock when I left work. Other times, it starts recording correctly then somehow it shows as if I decided to take off and fly over the city straight towards my destination.

    Sorry to say, but the troubleshooting steps listed above aren't useful at all.

    I do have auto-pause enabled and it's always been working fine for me for years. I'll try turning it off as see how it goes.

     

    UPDATE: Since a recent app update (end of February 2018), that issue is now resolved for me.

    2nd UPDATE: It issue is reoccurring since the last app update of March 9, 2018... What's going on, Strava?

  • Looks like I just got bit by this bug today on my 5s. Looks like it crashed or closed a short distance from my driveway. This thread is getting really long, so is there a summary of the current status and best practices to remediate? I lost the data from the first ride on a new bike today, and it's really disheartening to know that this bug has been happening to others for over a month now with nothing communicated. I would have checked throughout my ride had I known there was a chance of data loss.

  • OK. So uninstall/re-install, auto pause off etc. etc.
    Still misses off the first mile or so..............not happy
    Looking for an alternative app. Have been very happy until now. Cannot cope with unreliable software.

  • I am having the same issue as above, iPhone 6S...has always worked fine up until 2 weeks ago, and now acquires a signal but records no distance, it’s not tracking the run at all, strangely however it seems to track if I switch to cycling instead.....it’s Strava specific as I tried MapMyRun and that is working.

    Any updates on what is going on?!

  • As I'm still not running, I just use Strava to record walks. On Saturday I did all the usual prep, and I got a good reading. On Sunday I did it again, and used my Watch to record, for the first time since this started. It worked fine. The prep is time consuming, but seems to work. the steps I do are:

    1 Go to settings and turn off wifi and location services.
    2 Close all open apps.
    3 Switch off my phone.
    4Restart the phone.
    5 Restart location services.
    6 Open Strava and start recording.

    I go back to my home page and lock the phone before starting my walk. I don't stop autopause, as that is an important element when walking and wasn't highlighted by Strava as a potential problem.

    As with you all, I would love a proper fix. I don't dare try using the devices without the above procedure, until we are told the bug is fixed, as I may then miss a recording. So, any news?

  • iPhone 6S, tried all trouble shooting options no joy. Highly frustrating will have to find alternative if not sorted soon. Intermittent GPS, time record but no distance/stats shown

  • Yea. Both my iPhone 6 ‘s One work one personal.. neither work at all suddenly. It’s sounds silly but it’s killed a lot of my cycling.. 6 years of Strava addiction.. I have Garmin but uploading charging bla bla.. I need my phone to work again. I’ve done all the fixes... completely dead,,, auto pauses.. shows no movement. GPS on phone works other apps.

  • Same issue here too - tried all the above - nada; was working till mid jan - using iphone 6, but same issues when I use wife's android

  • i had a good couple of weeks with everything OK
    now its back to the way it was randomly stopping for no reason even though i am on the same route it has already tracked me on
    iPhone 7 user with no issues ever until this year

  • Have iPhone 6s and have only been using Strava for about a month.Operating ok until Wednesday 21st.Last 2 runs-recorded distance but did not record speed/km or total time.Also scribing of route all over the place like a MrScribble movie.Able to find elevations and some stats on the swipes.Have Tried most of the Fox tips without success.Any further bug fixes proposed by Strava?????

  • Well how interesting, someone above uses it for running and it fails but it works when switched to cycling. I tried mine on run last night and...........................it works. BUT it does not work for cycling.......................hmmm

    Why is STRAVA silent on this? Is something actually being done to find a solution?

    Wish there was a bit more feedback from the app developers...................

  • I've been using Stava since last June - no issues whatsoever until a few weeks ago when it just started to "jump" on my routes. I followed the trouble shooting instructions as above and it seemed to work, but only for 1 run. Very frustrating....

  • Second Comment, Did latest App. update on the 19th Feb. worked good for first ride & then has failed to last more then 10 minutes on all rides since then. Just turns off.

  • It worked! A test run today and it worked for all 3 miles..No voice though, but time, distance and pace..Didnt really change much, no reset, but did turn off wifi..

  • My iPhone 6S stopped recording on strava on 02/18/2018. I have been a Premium member for almost 7 years but I'm starting to reconsider my loyalty to strava considering recent performance issues. When I go to record, I'm getting a message "weak GPS signal" that eventually turns into "No GPS signal". none of the suggested fixes worked. Wifi is always off so that obviously is not it. I agree with other users who are pointing to the iphone gps as the root cause but it seems odd that strava has not investigated this issue more thoroughly. 

  • I have no idea what's happening with Strava but it's not helping my ruins one bit. My issues are: no distance or time breakdown recording of run, no voice progress messages. Actually, Strava is only working as a stop watch. I should add that I ensure I have GPS settings ready when starting run. I'll greatly appreciate receiving an answer and corrective measures from Strava - I've tried every potential solution listed in the chats.

  • Same issues since Mid December, intermittent but worse on running app. Big sections lost no segments : ( . Now noticing friends with same issues. Last 6 runs not recorded , with timings all over the place. Cycling at moment seems okay , though has omitted segments cycled. Cold weather ? Tried lots of the suggestions , log out log in , switch phone on and off . Shame will never get to running target at this rate ! Frustrating

  • Just happened to me today, half of my route was missin, but the other app which tracks my Heart Rate recorded the whole journey just fine, is there a way to fix the misrecordes route?

  • Doesn’t make sense, not working on my Iphone6s but I downloaded the app from cloud onto my work iPhone 7 and it works perfectly again???. I’m a bit surprised that strava is just ignoring all these comments and not even acknowledging them???

  • Can’t even open the Strava app. Just get the cogwheel running then it blanks out!!
    I’ve tried turning phone off, WiFi,locations and all other apps -with no luck. Don’t really want to have to reinstall and loose all my data. Any suggestions please ?

  • Update: I have attempted all solutions suggested on this blog, both by strava support and by users, and nothing works. I have re-installed the app and restarted my phone several times in different order. The app is completely unusable for recording activities. Since gps works perfectly fine on other apps, I believe this is a strava issue. My guess is that one of their software updates (probably intended to optimize performance on the new iOS and the iPhone X), may have inadvertently introduced a bug which prevents the app from recognizing the gps on older iPhone models. Specifically, the majority of bug reports on this blog are from iPhone 6S users, so that might be a good place to start trouble shooting if the strava software team is actually working on this. I don't think it's an iOS issue because mine is up-to-date.

    So Strava, please let us know whether you are working to fix this issue or is it time for us to start thinking about other ways to track our workouts?
    Thanks

  • As suggested, i used Strava today AND another app (at the same time) to record my run. The other app behaved flawlessly, whilst Strava 'lost' the first mile or so of the trace. so not a phone GPS issue, suggests more of a Strava issue. Can you roll back Strava updates?

  • It seems that everything is a little slower with recent upgrades desoite follwing recommendations from STRAVA and Apple.

  • FOUND A SOLUTION: updating the iOS to 11.2.6 completely fixed the issue for me. the software update was not automatic as with most iOS updates. I found that there was a pending update by going to Settings>General>Software update. Today I recorded a 6h ride with no missing segments and no gps drops.

  • I too have all the stated problems. I too have tried all the suggested fixes with no change in fortunes. I mostly want to know why Strava app developers are so silent on this issue when there are so many people experiencing issues. I think people would feel a lot happier if Strava would actually make a statement about what is happening or what is currently being done to look into the problem. I have read most of the comments here and there are a lot of people that bleed Strava but people will only stick around so long. Time is ticking Strava. What is going on?

  • Since installing the latest App update on 2/21, the Strave App on my SE, iOS 11.2.6 won't run. App opens, appears normal orange screen on startup, then screen flashes black, then shows homescreen. Looking at background for Apps running shows App open. Attempting to open App from background produces same result - starts as if opening, black flash, then homescreen. This is new since App was updated 2/21. Good luck, Strava.

  • I can’t get the application to open at all. Up until now it had been working fine for me. I have done most of the things on the list. Perhaps my Iphone 6s is simply too old.

  • iphone SE. I've used strava since 2012 and logged almost 700 activities. in the last 2 months, I've been plagued with these issues. Runs not being recorded, jumpy GPS, zero distance even though it seems to be able to locate my position accurately on the map. Updated the app at every opportunity, phone is up to date, reinstalled app several times, reset location settings, toggle all the various settings on/off . Occasional successful recording but mostly now serves as a distraction as i worry its not recording. and have to rely on friend to tag me on runs. Not ideal. Looking for alternatives now - any suggestions?

  • Just wanted to report, I have been having the same issues (iPhone 6S) as many have reported here, but with this latest Strava update everything is back to normal, working great.

  • Been having this issue for a few days now. Stava not recording anything. Purely acting as a stopwatch. tried all the suggested fixes. Any help appreciated, thanks
    Mark

Article is closed for comments.