iPhone app recording issues

We've seen a recent increase in the number of iOS users reporting GPS issues when recording but we aren't quite sure of the cause. This means the app freezes or stops mid-recording which results in incomplete data and missing portions of your activity. To help us investigate the issue, please try the troubleshooting steps below and let us know if it improves your future recordings:

  • Try turning your phone completely off then on.
  • Try turning location services off then on. Location services are located in settings > privacy > location services (turn off/on).
  • Try turning off wifi before and during recording. 
  • Close all other open applications before recording and if you open another app during your activity, navigate back to Strava afterward.
  • Lastly, sometimes recording data quality can be improved by giving your phone more time to acquire satellites prior to starting your activity. Try opening Strava when you have a clear and unobstructed view of the sky and wait a few more minutes than normal before starting your activity. 

Update: We've received reports that updating to iOS 11.3 has helped to improve GPS recordings on Strava.

Was this article helpful?
94 out of 240 found this helpful
Have more questions? Submit a request

Comments

126 comments
  • Have tried all the suggestions above - & reinstalled the app etc, but tonight I recorded 35 minutes and zero distance. Same result for the last 2 weeks.

    It would be great if someone from Strava could give us some sort of explanation or update on a fix. Thanks.

  • Iphone 5, did updates on the 7 Feb and next two rides have been cut short, did this a few months back and a following update seemed then fix it.
    Starts OK, When I'm finished and go to stop the ride it is already stopped and app is turned off, only recorded the first 10 to 20 minutes of the ride and the shots to the end on the map.

  • Turning phone and location services off and on again didn’t work

  • same here just started happening to me last two weeks
    app also freezes and shuts down
    started happening before the last iPhone update

  • Same issues since Mid December, intermittent but worse on running app. Big sections lost no segments : ( . Now noticing friends with same issues. Last 6 runs not recorded , with timings all over the place. Cycling at moment seems okay , though has omitted segments cycled. Cold weather ? Tried lots of the suggestions , log out log in , switch phone on and off . Shame will never get to running target at this rate ! Frustrating

  • Had it freeze up on every run of 2018. I tried all of your resets and running with it out of its case.
    No change.

  • I am having the same issue as above, iPhone 6S...has always worked fine up until 2 weeks ago, and now acquires a signal but records no distance, it’s not tracking the run at all, strangely however it seems to track if I switch to cycling instead.....it’s Strava specific as I tried MapMyRun and that is working.

    Any updates on what is going on?!

  • It worked! A test run today and it worked for all 3 miles..No voice though, but time, distance and pace..Didnt really change much, no reset, but did turn off wifi..

  • I am so glad I finally found this thread - the malfunction is driving me mad. I tried everything (have an iphone 6) and it has been the same issue fora week now: 3 of my 4 runs, the app would only show moving time but no distance or time per km. When I finish it seems to show a distance but the time/km split often seems off (eg showing me an under 5min average when each km was run in over 6 min individually). I initially thought it was me using Bluetooth headphones, but even without them it would record a run to about 7km and then stop and not record even my moving time anymore.

    I deleted and re-installed, I turned location services on and off, I turned Wifi off, i started and restarted phone and app. I have always used Spotify in parallel on my runs so that should not be a reason for it to suddenly stop recording proper.

    Help!

  • I've encountered similar problems on my last three runs this week. I have tried most of the suggested troubleshooting steps above but I'll now try location settings before my next run and report back.

  • I am getting sick of this, I cycle to London and back home daily and the issue started suddenly with my Iphone 6; wrong recordings, missing a few miles and sections to not recording sections and picking only the start and finish. In the last few days it now shows just a straight line with no sections and less mileage... I started switching off the wifi (pure guess) and that worked for a few days. Yesterday the GPS finally "lost it"... in the morning it showed an average speed of 122mph (yeah right) but a maximum speed of 22mph... and no distance recorded! Last night strava lost the plot completely, it shows a picture of the start but 0 everything! Useless.

    This morning I used my old Samsung S2 (yes you read correctly) and it recorded the entire thing properly.

    I just read the "suggestions from Strava and turned the location off, and switched the phone off too. Lets see if that works!

  • Strava has been doing this very frequently as of late: not recording the first mile or two of a run. It is very annoying

  • 3 runs in a row I've had major GPS issues with the app, i'm no hard core athlete but do find it most frustrating not being able to see my progress, I have an iPhone 6S, last two runs despite hearing the app working when uploading it has recorded no activity. Might it be linked to recent IOS updates? Like others I really hope a solution is found soon before I give up on it.

  • Same issue here too - tried all the above - nada; was working till mid jan - using iphone 6, but same issues when I use wife's android

  • When I run stairs the time of my run that shows is only about half of the actual time. However, the entire course I run shows on the map.

  • I too have had problems recording my cycle training (in Dubai using an iPhone 5S). Now I have ordered a Garmin Forerunner 235, cant keep losing my distances. Strange but seems a recent problem when reading all these comments.

  • Yea. Both my iPhone 6 ‘s One work one personal.. neither work at all suddenly. It’s sounds silly but it’s killed a lot of my cycling.. 6 years of Strava addiction.. I have Garmin but uploading charging bla bla.. I need my phone to work again. I’ve done all the fixes... completely dead,,, auto pauses.. shows no movement. GPS on phone works other apps.

  • Just happened to me too after following these steps. Have only had one activity recorded this year. Turned phone on and off, had WiFi off, waited till I saw it had a GPS sync before I started running. Didn't not track anything. iPhone 6s.

  • Had another successful recording last time out. It really takes a lot of prep to shut down apps, restart phone, restart location services and disable WiFi! Then several steps need reversed to get the phone back to normal operations. As I’m recording walks, with breaks, I don’t switch off auto pause. It is now over 3 weeks since first reports appeared, what is progress on a solution?

  • Second Comment, Did latest App. update on the 19th Feb. worked good for first ride & then has failed to last more then 10 minutes on all rides since then. Just turns off.

  • Tried with ridewithgps last night and this morning, works fine. Premium member since Nov 2014, what to do?

  • @Ken, we're mostly referring to the iPhone app recordings. If your watch uses the phone's GPS then this known issue should include you too.

    Sorry to hear @Jen, if you haven't already you're welcome to start a support ticket with us so that we can try further troubleshooting.

  • I started having this problem since I updated the strava app on my Apple Watch about two weeks ago. Prior to the update I didn’t seem to have any issue with it recording accurate data. Now every time I run it records incorrectly.

  • Any word on a fix? I'm having the same recording problems and I've tried all the suggested fixes, except turning off wifi b/c when I opened Strava w/o wifi active it told me wifi will improve accuracy. I know I can ignore that warning, but seems contradictory. This may be related to acquiring the gps signal, starting in my work parking garage is understandable, but doesn't seem like front porch on a one story single family home should get in the way. Also, how can we tell? The app says "signal acquired" Can you fix that? If not acquired, maybe the app shouldn't say it has. I like the way Strava presents results, totals, segments and the social aspects, but getting too frustrated with the lack of accuracy.

  • Similar problems on iPhone 6s for past three weeks: when select record GPS acquires signal and start ride time starts ticking but it does not record distance. When I stopped to check on recent ride the GPS knew where I was but no distance had been recorded. In all cases the app starts working properly at some random point and records the finish of the ride. The map shows an as the crow flies straight line to where it started to record. V frustrating. What’s happening Strava? Thx.

  • I'm seeing this issue as well (iPhone 8, iOS 11.2.6, Strava 37.0.0). I start my run and after 5 minutes I look at my phone and the only number changing is the time. Distance and pace are both at 0 (it happened once mid run as well that everything got stuck). I've had it happen with RunKeeper as well though so I think it might be an iPhone / iOS issue.

  • i had a good couple of weeks with everything OK
    now its back to the way it was randomly stopping for no reason even though i am on the same route it has already tracked me on
    iPhone 7 user with no issues ever until this year

  • Something that seems to have resolved the issue for me is an app called GPSdiagnostic. It’s designed to calibrate and reset GPS. I have since done 3 runs with no issues what so ever, having previously not been able to get any consistent GPS lock. It costs 2.99 I think but well worth it, hope this helps people out as I know first hand how frustrating it is to not be able to log stats.

  • Had the same issues, either I get zero data, just auto paused straight away basically, or a couple of times I have had the first half of my ride “as the crow flies”.
    Tried the work around, tried uninstalling and reinstalling the app.
    No joy.
    Seems to be a worryingly common problem, iOS users account for a large portion of Strava users I would say, might be time to pull the finger out and get a fix sorted quickly.

  • I've had the same problems, but only in the last week. I think its down to the update to OS 11.2.6 which I did around the same time. I'm using a Polar H10 heart rate monitor and their Polar Beat app which has previously worked flawlessly in exporting all data to Strava. Everything seems fine setting off on a run, GPS signal is acquired, all seems well until the lack of voice guidance doesn't kick in. Time and HR data is recorded but no distance or route. I've tried just using Strava with no other apps open - small parts of runs are logged with "as the crow flies" bits. It's very frustrating as I'm counting on this info to help train better for a marathon. Premium doesn't seem worth the money now that even the basic premise of Strava isn't working.
    I've done all the suggested fixes: resetting the Location services, resetting network settings, turning off wifi before an activity, waiting longer for GPS signal before starting... but nothing works. other GPS based apps seem to work Google maps and waze, so I'm not so sure its the iphone. I'm just hoping that there's a quick update fix from Strava.

Article is closed for comments.