Android Update Required

We are upgrading Strava's network security systems on November 8th, 2018 to make sure your data continues to be as safe as possible. This change requires that all athletes have a more recent version of Strava to continue using Strava on Android devices. After 11/08/2018, if you are seeing errors such as "Data sync failed," "Network unavailable," or something similar, please make sure you have the following installed:

  • Android KitKat 4.4 or later.
  • Strava app version 51.0.0 or later. The latest update can be downloaded from the Google Play store.
Was this article helpful?
9 out of 11 found this helpful
Have more questions? Submit a request

Comments

0 comments

Article is closed for comments.