Route Builder Troubles

I create quite a lot of routes on the route builder to keep training runs interesting and especially when I am riding an unfamiliar location.

A short while ago I stopped being able to use the scroll wheel on my mouse to zoom in/out of the map. In addition the pointer arrow is always the hand icon instead of the pointer. It still allows me to drop a pin but it is strange that it has started happening. It is the same on my laptop as well as my desktop.

Is it just a case of my software is out of date or just an issue with Chrome. Or is it a change on the design?

Thanks.

24

Comments

41 comments
  • Official comment

    Hey folks - 

    The big issues that were on our list for the Route Builder have been resolved. There may still be some quirks and glitches as the feature is in Beta and is not currently being worked on in development. Feel free to report other issues, but we may or may not have a timeline in place to address them. Thanks for your patience. 

    Comment actions Permalink
  • Hi Michael,

    We have some open cases with the engineering team to address some of these Route Builder issues. We'll keep you posted and we hope to clear up the trouble soon! 

    0
    Comment actions Permalink
  • I'm having the same issues with this program. Also, the flat hand pointer is keeping me from being able to double back over an already laid down route. Program was working great until about a week or so ago. 

     

    Clayton.

    2
    Comment actions Permalink
  • Yep Clayton, I've reported that additional issue as well. Things may be a little slow over the holidays but I hope we can pick this up soon and resolve the issues. 

    1
    Comment actions Permalink
  • While on the subject of issues, what happened to Globe Heat Maps and the ability to show bike paths or streets that are bike friendly? Used to be an On/Off toggle switch and it's gone now. 

    1
    Comment actions Permalink
  • Thanks Elle, this has been driving me nuts recently and was going to submit a post. Glad to see it's in progress :)

    1
    Comment actions Permalink
  • Hi There,

     

    Has there been any progress on this??

    I have used both my mac and pc, aswell as changing the browsers (firefox and chrome) same issues.

     

    0
    Comment actions Permalink
  • I'm working with the engineer assigned to these route issues. We believe we've fixed the "cannot double-back on route" and the issue with the heatmap, and with the elevation "rabbit" and with the zoom scroll. 

    Can I have those of you on this thread verify? 

    1
    Comment actions Permalink
  • Elle, I can confirm that "double back on route", heatmap, elevation, and zoom scroll are no longer an issue for me on PC. Haven't tried with any other platform. Thanks for the fixes.

    0
    Comment actions Permalink
  • Seems to be doubling back now and working ok.

    Zoom Scroll also working for me too.

    Thanks

     

    James

    0
    Comment actions Permalink
  • Hi Elle, I seem to still be having issues. When you type in a postcode to start planning a route it no longer zooms to that area, so you have to look at googlemaps to find where to begin or finish. I work on a mac if that makes any difference!

    Thanks

    Bryony

    0
    Comment actions Permalink
  • My route location pin missing.

    The above problems look like they've been fixed, one problem I as having was that when you viewed a route before you could move the mouse over the elevation profile and a location pin would show on the map, if you scrolled across the profile the pin would move about on the map. This doesn't happen any more. However if you edit the route then you can see this location pin. This problem seemed to happen around the same time as these other changes.

    I found that quite a useful feature when planning routes, please add it back.

    I'm using Chrome on Windows 10, I've also checked on Edge and on Safari on a Mac with the same results.

    Thanks, Joe.

    2
    Comment actions Permalink
  • @Bryony, I've typed in a few post codes both US and European and the map zooms for me. Can you give some examples of what post codes don't work for you? 

    Thanks @Joe, I've heard this from a number of other users and I will see about it getting added back. 

    0
    Comment actions Permalink
  • I've had the wheel zooming problem one and off for a couple years. Right now the heat map toggle is not working. 

    1
    Comment actions Permalink
  • Still seeing this issue with the heatmap Jesse? 

    0
    Comment actions Permalink
  • Hi Elle, Yes, all fixed today. I'm using Chrome on a chromebook but at times I've noticed either the heat map missing or other issues on multiple browsers/systems. Then when I look at it another time all is fine.

    This probably belongs elsewhere, but here are my thoughts: I've been using the Route mapper for over three 3 years. I've ridden the 30-50,000 miles with a phone on my bars and an external battery. I've been all over the place mostly do to MTB racing  

    My goto technique for finding most routes, to make this as short as possible, is to use the segment explorer for a given area. I find the most popular segments (often off road).  I then start looked at the top riders on the segments and and clicking on their rides. Often in a given park trails I'll start to see similar routes appearing, and end up choosing one that looks like it's popular and most often a favorite loop of a local rider. I then save the gpx to the phone and ride it, most often in an app call Maps3D (IOS and Android Beta). 

    Short of that I create my own routes often based on some of those same routes.  and often, of course, I use the activity search. 

    I also use googles routes too, which are also easy to drag and drop, then turn them into a gpx using gpsvisualizer.com 

    Strava routing is my primary tool though. I would say one thing that that would be pretty involved but would improve the system incredibly is if users could start tagging segments/trails as to their nature. I'd like to see, road, rough road, dirt road, gravel road, (fire road), single track, double track, technical... and for road whether they are bike shared, bike friendly, or segregated bike lanes, or even official bike routes.  I'd love to basically tailor the type of ride I'm after. 

    Alas one thing I find around London currently is many of the popular heatmap routes are actually the major routes that commuters are taking to get to work, but they are not necessarily the best routes for your Sunday training ride. It'd be great to somehow differentiate some of these roads. 

    If there were a possible way to rate the segments as the best to take....     There's a number of routes that are efficient and fast, but share a major A road and even if you're segregated your essentially riding next to a freeway! It can be horrendous. Meanwhile nothing beats the country lane, yet it's very hard sometimes to figure out what is what when you're laying out routes using the heat maps. 

    I was sold on Strava Routes when I mapped a 328 mile trek from Philly to Harrisonburg, VA, and the heat map route took the most lovely route the way including 4 or 5 covered bridges. 

    0
    Comment actions Permalink
  • March 5 2017: Route builder appears to be completely broken. I cannot save a new (or edited) route and the UI is exhibiting erratic behavior such as deleting an entire route when I try to add a waypoint and not allowing me to manage start and end points.

    4
    Comment actions Permalink
  • Same goes here: route builder broken doesn't allow me to save any route after editing. Loading takes forever, without any result.

    2
    Comment actions Permalink
  • I am also unable to edit or save any routes using the route builder, pretty annoying as trying to put together a routes library for club runs, any idea when it will be fixed?

    0
    Comment actions Permalink
  • Glad Im not the only one! The editing route used to be great. Hoping this gets fixed asap! 

    0
    Comment actions Permalink
  • The route builder used to show national cycle routes on the map but doesn't seem to anymore - a real shame - makes it more or less unusable for distance planning on trips...

    0
    Comment actions Permalink
  • I can't edit routes based on my friends activities :/

    0
    Comment actions Permalink
  • Heat Map is no longer working within Route Builder. This was the BEST feature of Strava. Is it going to be fixed?

    1
    Comment actions Permalink
  • I am currently having issues on multiple computers with the heatmap loading on the route builder. 

    I can see the heatmap correctly when I am zoomed out but if i attempt to zoom in the heatmap does not show or only half shows. 

    I tried this and had the same issue on multiple computers with multiple browsers. 

    1
    Comment actions Permalink
  • I have since a couple of weeks on 3 different PC's with 3 different browsers (chrome, Firefox and IE) problems with the strava builder. i don't see any map, the map screen keeps empty!!!

    0
    Comment actions Permalink
  • Steven, I've created a ticket for you. This is an easy fix and is just a stale Google location for your account. 

    Rob, Bret - may have been a temporary issue as from what we know the Heatmap is working fine now. 

    0
    Comment actions Permalink
  • I have the same problem as Stephen

    1
    Comment actions Permalink
  • Michael,
    Try to give a village or city in the search field, the standard settings (your home adress point) given in your account are maybe the problem. It least this works for me.

    0
    Comment actions Permalink
  • Hi, I have the grey screen in route builder. I've tried changing location, adding different towns in the builder and in my profile settings....but still no good.  Any ideas? Thanks

    0
    Comment actions Permalink
  • Hi, I am a bit of a novice with the route builder but have been building a number of routes in my local area for my own use. In the last week I decided to upgraded to Premium but since then I have noticed that when viewing a route the pointer on the map does not move (just changes colour and remains at the start) when I scroll across the elevation view. I am sure I used to be able to do this and it was useful to see where the bumps would occur on the route.

    Is this a user issue, something that is not available as a Premium user (doubtful) or a common issue that others are experiencing.

    It seems to work if I view other users routes on flybys.

    Thanks in advance.

    4
    Comment actions Permalink

Please sign in to leave a comment.

Didn't find what you were looking for?

New post Agent Only: Button marked