"Too fast" pace and distance data discrepancies

I went for a run yesterday and recorded the run with my Garmin Fenix 3 HR.

https://www.strava.com/activities/872864376

I was running with a friend who recorded the run with his Garmin Forerunner 230.

https://www.strava.com/activities/872855492

We ran side by side the entire run.

In Garmin Connect - this run is shown as shorter and with correct "moving time" and "elapsed time" I am happy to email you the .gpx file. - https://connect.garmin.com/modern/activity/1582333209

Specifically, from 14.7k to 15.2k the Strava activity shows me running in the range of an unrealistic 1:00min/k pace. At the same distances in Garmin Connect, these errors do not occur and my correct pace is shown. So the watch recorded the data correctly. Strava software inserted the "bugs" on import.

I have had runs in the past with similar issues, so thought it was time I asked the question.

I also "flagged" this run - which took me off several leaderboards that I like being on. I wasn't sure what the deal with flagging was. Anyway I would appreciate the run being "unflagged" even if the issues cannot be resolved as the overall distance is not way off and is, at the end of the day, the most important stat to me.

Hope this helps resolve what seems to be an ongong issue.

17

Comments

36 comments
  • This is the "genius" Strava moving time algorithm that can't handle gaps in GPS data correctly. What likely happened is that your watch temporarily lost GPS reception and logged erroneous entries without position (but with speed). Strava happily ignored the speed (because it knows better and always recalculates the speed from distance between GPS points) and the considered those to be stationary. Then you ended up with a long "jump" to the next know position where Strava calculated speed on now significantly shortened moving time.

    This happens a lot on challenging mountainous terrain because satellites are often blocked by terrain and tree cover. Strava still insists on its algorithm and uses it even for hikes where results sometimes are even more ridiculous.   

  • I have the same issue. My watch didn't lose GPS. What I did is that I manually paused the run while I was taking short little walking breaks. Strava seems to think that instead of walking, I moved at about 1 min/mi pace through those breaks. I think it's not managing to handle the pauses properly, the elapsed time equals the actual time so it thinks I'm 500ft away in a second...

  • I've given up on Strava after constantly dealing with this. My garmin is tracking and holding signal just fine but as an example, today I ran 5km and strava said it was just over 8k. Way too inaccurate so I've now deleted the app as it's pointless with data.

  • Similar issue here - Strava reinterprets perfectly good data from Wahoo speed sensor and produces wrong speeds (max and average).

  • I have a Suunto watch. Recording interval every second. Running a route in open country with a 'buddy', my Suunto pace is fine on the Suunto Movescount site. But when translated to Strava, it gives me a ridiculous running pace. A 1hr. 18min. run, is recorded as 1hr.15 on my friends Garmin when put on Strava. My run has 35mins. as moving time, despite the o/all run time of 1hr.18min. So my 'running' pace per mile is much too fast for all miles.  Observers think I have developed my running speed to a world shattering level ! I am a bit miffed with Strava !!

  • @Gareth JonesI followed a discussion on Facebook recently where it was claimed that Strava admitted that there is an issue with upload of FIT files specifically from Suunto movescount in which case Strava moving time algorithm cuts way more time than necessary. According to the person who reported that, importing the same run as a GPX file produces a way better result (but then barometric altimeter elevation data gets lost).

  • I'm having significant problems with Strava cutting moving time from my Suunto Movescount uploads. I noticed that something might be wrong maybe two or three months ago, but I've noticed it being ridiculous over the past month when my "runs" have included hiking up mountains at more than 1,000' per mile (sometimes closer to 1,200-1,500' per mile). This evening, it cut 16 minutes off a 30-minute climb, resulting in a completely inaccurate total moving time, pace, etc. (https://www.strava.com/activities/1579085010) Looking back at a compared run from June of last year, it wasn't an issue at all then.

    Come on, Strava. Fix this.

  • Same issue with Suunto Movecount. No matter where, trails or roads, my time running is too fast and does not agree with Movescount.  This just started happening, but I will have to disconnect from STrava if it continues. PLEASE HELP>

  • I’m also having a ton of issues with my Suunto Ambit 3 Peak and uploads to Strava. The pace differs from what the watch records, sometimes significantly. And, the elevation gets multiplied multiple times and needs to be adjusted for every run.

    Please address this soon.

  • I have an issue with the movescount to strava upload, I did a 34km 'hike' in 6hrs, yet on strava my moving time is 1hr19mins with a terrific pace of 2:22mn/km, even though the data records the distance and time as movescount.

    Can anyone help with this issue, or know what I need to do to edit the data so it reflects what actually happened.

    Thanks in advance.

  • Every run I do now is recorded wrong this stinks

  • Same issue here. A leisurely 7 mile walk with family took about 3hrs on movescount and strava then interprets that as 34min; calorie burn is fantastic though!! Which joking a side is quite annoying as I do try and use it for counting calories.

    I've never seemed to have any issues with my runs though. I wonder if it has something to do with the GPS refresh as I'm sure I set the refresh rate for longer times when walking to save the battery.

    Will give it a try today and set my watch as if I would for a run.

     

    EDIT: Went for a longer walk, 13.4miles, distance spot on but timing just out by 30min this time, 4hr30 on movescount ended up as 4hr05 on strava. Still not great but better. Still think it must have something to do with the "Walk" setting as opposed to the run, battery drain was definitely more significant as well; used about 55%

  • In the same boat. Seems to have just started happening in the past month or so where Strava drops a significant amount of time off my runs that I am uploading from my Suunto Spartan Trainer via Movescount. I feel like it should be fixable since it was not happening previously. Trying to decide if it’s only happening on runs where I pause like when I get to a peak and take a break before running back down? I’ve read gaps on GPS data can cause it to do that but it wasn’t a problem for me previously so am pretty frustrated. I LOVE Strava but the inaccuracies are making me look bad.

  • I’m thrilled with my new Suunto watch but absolutely disappointed in Strava. The data on the Movescount app is accurate but once uploaded to Strava it shows inaccurate speeds/pace and incomplete time, but accurate total distance. I’ve used GPS settings at both “best” and “ok” settings. What gives Strava?

  • Has there been any resolution to this? My Ambit3 just started having trouble with strava . Today - overall run 3:03 non stop with a pace of 6:09 on trails.MC has it right. Strava reporting 2:40 run time with a 5:24 pace?  And, I always have to do auto correction to elevation.  

  • I’m not sure the reasons, but the solution given to me from a friend and fellow Suunto wearer is to adjust the activity after it uploads to Strava to a “Race” activity. For some reason that does the trick.

  • Same problem between movescount and strava.

    Strava cuts a lot of time.

  • Suggestion to adjust an activity to race comes up all the time. It kind of works because it switches time and pace from moving to elapsed, but it is a terrible workaround. Race means race to me and all my followers on Strava. Races are marked prominently in the feed and in the activity log, and I definitely don't want all my runs to look like races. That would be very confusing and will make it difficult to locate actual races in the log.

  • Jack Bailey, please discribe exactly your solution.  Do you change the activity on MovesCount or Strava?  And how exactly do you change it..  More details please.

    https://support.strava.com/hc/en-us/community/posts/115000091670/comments/360002135631

  • My solution was to cancel premium and stop supporting a service than can’t deliver a base level of clean data.

  • Gary, on Strava, you adjust the activity type to a race. It does change closer. 

     

    For me, I would rather see Strava fix the issue. I can't believe for the life of me, that a fix cannot be found. The user should not have to adjust something to make it work. They still haven't fixed the elevation issue either. I won't renew premium because of this. I know I know...I'm a rebel at heart. 

     

  • I,m a Suunto Ambit 3 user. Movescount records run data perfectly. Strava cuts my elapsed time several minutes on a 8 or 10 mile run which makes my pace look ridiculously fast. I like using Strava to keep up with friends activities, but it's embarrassing to post my runs. I always manually write in my real pace and time in the description of every run I post. What a pain!! 

  • I just found this with my new Ambit3 Vertical (haven't really checked before with my old Peak, but haven't used it for a while).

    My 'workaround' was to delete the runs that got automatically synced into Strava, then manually export the GPX files from Movescount & add them manually back into Strava. This got closer to the actual pace & moving times.

    (Manually adding the FIT file resulted in a shorter moving time, as per the auto-synced version).

  • Hi Mark - yes, that does kind of work and appreciate you sharing. But in my opinion, it's a lot of effort for something that should happen automatically. They seem to have figured it out with Garmin devices. I cancelled my premium account and will likely migrate away. Knowing that issues like this exist, really calls into question the data and information I look for and like to follow with people. I already know many segments are polluted (with wrong activity types entered), but having incorrect data in there just adds another level. 

     

  • Also having issues between Suunto and Strava which were initially not too bad unless I corrected the distance, then they were way out. Today though, another parkrun (so 5km), and Suunto time was 22:01, Strava time was 21:01? I have no idea why it has dropped my time by a minute (looks better clearly but is not accurate).

  • I have been using Suunto and strava for years and only started having this problem in the last month or so. Extremely frustrating.

     

  • uploading the GPX file fixed the problem. Painful to have to do that every time though

     

  • As noted by Stanislav C. importing the GPX manually for me seemed to resolve this to a degree (aside from barometric altimeter elevation). Maybe it's worth hooking into their API or similar, disconnecting movescount from strava and creating a separate connection to re-create the manual transfer autonomously or scheduled. Of course we could maybe charge strava a nominal fee for this service until they decide to parse data correctly without ****ing it up :) 

    Please don't get up set by this Strava but you really need to sort this before you get overtaken (little running joke there).  

  • I have the same issue.  Suunto Ambit 3 Sport, Strava is cutting minutes off my moving time and making me look way better than I am.  Running with a friend on Garmin shoulder to shoulder and get same results in Garmin connect and Movescount, but completely different when they both load to Strava.  This is really frustrating.  I don't want to set everything as a race as there are pauses which I don't want the time including for etc. so I don't want elapsed time I want a correct moving time to be shown.  Uploading GPX manually doesn't fix this for me, I still see very different moving times in Strava compared to Movescount.

  • This is what Strava sent me on this topic. I gave them two recent examples. Bottom line...we either convert to race or forget about it being correct. The first option she mentions distorts the time even worst. lol

     

    Hi Corey, Thanks for sending that over and sorry about the discrepancies between Suunto and Strava. Unfortunately, this is an issue with how the activities are being recorded on the Suunto device. The issue is how the moving time is being calculated and recorded in the Suunto file itself that is sent over to us. The original file contains numerous data errors that cause problems when they are pushed over to Strava. We are working with Suunto to resolve the issue on their end, we appreciate your patience. In the meantime, I have included two suggestions to try and get your data a bit closer.

    Suggestion 1 - To swap your distance stream: This will remove the outlier points from the device recording and rely on the GPS data instead. Click on the link directly below your current distance listed on the Activity Details page, where it says "Distance(?)" in small letters. From the pop-up, click "Correct Distance". When the status changes from "Calculating" to "Updated," refresh the page. If you would like to revert the change, you can click the same link and click "Revert Distance".

    Suggestion 2 - Tag activity as a race: This will force the activity to read the total elapsed time instead of the inaccurate moving time. Go to the edit screen for the activity in question Mark the activity as a Race Hit Save

    For more information, see our article on How distance is calculated for your activity (). Please let me know if there's anything else I can help you with. Cheers, Jess Strava Support Team

Please sign in to leave a comment.

Didn't find what you were looking for?

New post