Wahoo RPM Cadence only sensor pairing

I bought a Wahoo RPM cadence only sensor and when trying to pair it with the Strava iPhone app it cannot do so under the cadence only profile. It always pairs under speed+cadence profile. No devices are even searched for when the cadence only profile is enabled. Is this expected?

1

Comments

46 comments
  • Elle Anderson, what info do you want us to share knowing this is a public forum?

    0
    Comment actions Permalink
  • @Rob, 

    By info I simply meant a summary of the issue as you're experiencing it with all the relevant specifics and troubleshooting you've already tried. Thanks! 

    0
    Comment actions Permalink
  • Please refer to the help article on Issues connecting Wahoo Cadence sensors for additional information and troubleshooting, and to let us know if you're still seeing this issue. 

    To note, selecting the Cadence (only) toggle unfortunately does not work for the Wahoo sensors. You'll need to select the Speed & Cadence option in the Strava app devices settings. 

    0
    Comment actions Permalink
  • I recent bought the Wahoo rpm speed+cadence set of sensors and experienced the same issue - could only get data from one or the other.
    I was able to get them both to start working correctly- some people state intermittent functionality- not sure if it will stop again- but here's what I did.

    1- I updated the firmware of each sensor by pairing with the Wahoo fitness app (not the utility).
    2 - I removed the pairing from Strava
    3 - I paired the cadence sensor with strava as a speed+cadence device. (removed the speed app from range).
    4 - I brought the speed sensor back into range.
    That was it.
    The next ride I took, both speed and cadence were functional. It has worked for the past 3 rides without issue.

    2
    Comment actions Permalink
  • I followed a process mentioned in another comment:

    1 - remove ALL sensors, including heart rate

    2 - start with speed & cadence switch, add cadence

    3 - add back heart rate sensor, power, etc.

    this worked for me.

    I do still wish the Strava app would register my speed sensor, as of right now they only measure speed via GPS. Also if you're going to have a Cadence sensor switch, it should work. Thanks!

    2
    Comment actions Permalink
  • Herman W's solution fixed my problem too.

    So it seems that if you are using the wahoo chest strap with the app, the app somehow thinks that the chest strap is also the cadence sensor, so even when you register your cadence sensor, the app is still trying to read cadence from the chest strap.

    Removing all the devices, and then adding the cadence sensor first, and then the chest strap, fixes the problem.  I would guess that the app uses the first registered cadence sensor, thus does not work if the chest strap is registered first.  This is something for the developers to look at!

    Thanks Herman W for the fix!

    1
    Comment actions Permalink
  • i finally got it to pair/work... it shows me the cadence while in record or activity mode... but i cannot see any cadence info in app once the activity is saved and synced. it does show me on the web version much the same way as watts and speed...

    am i looking at the wrong place in the iphone app.

    i have the latest updated app and cadence is with Wahoo.. ..

    thanks in advance, love the app!

    0
    Comment actions Permalink
  • I've also added the above tip to the new help article on the topic. Thanks! 

    0
    Comment actions Permalink
  • The proposed solutions of only pairing the cadence sensor and not using the speed sensor is really not acceptable. I do a lot of cycling in NYC where things like bridges and tunnels block GPS signal and mess up the speed readings. Why does Strava not support speed sensors?

    0
    Comment actions Permalink
  • @Nick, I don't have a good explanation for you, but it's not something we are exploring with the mobile app. Distance based on GPS isn't perfect, but it's consistent across all Strava-supported devices. 

    0
    Comment actions Permalink
  • I cannot connect Wahoo Blue SC at all. Does not detect the device. I have no problems using it with Wahoo Fitness app and connect straight away. Endomondo detected the sensor as well but shows only cadence. In Strava Record Activity - Menu button - Sensors - Searching for --- and nothing found.

    I can set up sharing with Strava in Wahoo app but I want more details during the ride.

    0
    Comment actions Permalink
  • Priidu, make sure you check the steps we recommend for troubleshooting, and if that doesn't work please contact us directly via a support ticket. 

    0
    Comment actions Permalink
  • I have a sumsung note 4 running android  and cannot get the wahoo Rpm sensor to show up at all . It however works fine on the wahoo utility app .

    0
    Comment actions Permalink
  • Might have sorted some thing out . I deleted the wahoo utility app and did what a previous poster did and use the wahoo exercise app to connect the RPM and now strava sees it after I also shared the data with strava on the wahoo app . Will see if it works when I  ride tomorrow .

     

    0
    Comment actions Permalink
  • I'm experiencing this issue as well.  I have the Wahoo RPM Speed and Cadence sensors like the ones linked here (https://www.amazon.com/Wahoo-Cadence-Sensor-Android-Computers/dp/B01E0YRQIA/ref=sr_1_1?s=sporting-goods&ie=UTF8&qid=1483555971&sr=1-1&keywords=wahoo+speed+%2B+cadence).

    I have a Nexus 6 device that I use and the cadence sensor pairs but the speed sensor does not.  I've followed the instructions posted as well as the Wahoo Fitness trouble shooting instructions that work for their app in hopes it will work for Strava with no luck.

    So does Strava not support speed sensors and just go off GPS?  If it does not support the speed sensors, is this on the docket?  I've been a premium member for a few months and would like to see this incorporated into the app.  As of right now, I've canceled my subscription because of this issue and have just fallen back on strictly using the Wahoo Fitness app with both of these sensors.  Once Strava incorporates this in I'll re-subscribe.  I love the beacon feature, this gives my family a peace of mind and they can check on me where I am on my route but the speed sensor is a deal breaker for me.  I'll just have to find some other beacon solution or make my own while I use the Wahoo Fitness app.

    -1
    Comment actions Permalink
  • I just got both sensors as well.

    I noticed that the only way to pair either sensor is by switching the Speed & Cadence sensor. You can actually pair either one to that mode and I thought that maybe by pairing the cadence first, waiting until it's off, then the speed after it would sync "both".

    When I did that I did notice the number of sensors connected to the phone (before you start your ride was 3: my heart and probably the other 2 sensors, speed and cadence..)

    However, under removing sensors I only see one the last one I connected it to. So that's odd..

    I'm going to try a ride later tonight and see how it all works out..

    I haven't take it out for a ride

    0
    Comment actions Permalink

Please sign in to leave a comment.

Didn't find what you were looking for?

New post