After iphone iOS 12 split voice changed

Has anyone noticed that the Strava voice for the splits and mileage is different since the new iphone update.  It's a terrible computer voice now that is barely understandable.  Can this be changed? 

10

Comments

28 comments
  • Looks like we posted about the same time. I've asked Strava on Twitter about this and gotten no response.

    0
    Comment actions Permalink
  • Yes it is really bad. It has also changed in some other running apps. Don’t know how to change it yet.

    1
    Comment actions Permalink
  • Me too. Really want to change this voice!

    2
    Comment actions Permalink
  • Since the update I can't seem to get the voice to work at all.  Is it only available on the paid version of Strava  now?

    0
    Comment actions Permalink
  • I second the above comment. I can’t tell what the new voice is saying. Please fix this!!!

    0
    Comment actions Permalink
  • I have the same issue!! It's horrible. I miss the old voice!

    1
    Comment actions Permalink
  • Yes, I have the same symptom. Is there an update coming out to address this?

    0
    Comment actions Permalink
  • I have the same issue. Quite unpleasant... No hints anywhere at how to change it back. Help!

    0
    Comment actions Permalink
  • Hey Folks, 

    Thanks for reaching out. We're aware that due to the recent iOS 12 update, changing the settings for Siri have affected the Strava Audio Announcements. We're currently looking into this change and appreciate your patience. At this moment in time, we do not have the ability to revert back to the original Siri voice within Strava.

     

    While we continue to investigate this issue can you help answer some of the following questions:

    1. Can you confirm if you recently changed the settings for Siri?

    2. Did you update your iPhone to iOS 12?

    3. Can you confirm what version of Strava you are using?

    4. Can you let us know what language your phone is in and what language/accent Siri is set to?

     

    You can find Siri's voice settings under Siri & Search on your iPhone.

     

     

    Cheers!

    0
    Comment actions Permalink
  • 1. I never use Siri, so I have not recently changed any settings around that.

    2. Yes. My phone is running iOS 12.

    3. Strave v65.0.0 (13515)

    4. Siri Voice is set to Accent: American, Gender: Female

    Let me know if anything else from my phone would be useful in debugging this.

    0
    Comment actions Permalink
  • 1. Can you confirm if you recently changed the settings for Siri? NO

    2. Did you update your iPhone to iOS 12? YES

    3. Can you confirm what version of Strava you are using? THE LATEST

    4. Can you let us know what language your phone is in and what language/accent Siri is set to? PHONE IS IN UNITED STATES ENGLISH. SIRI IS AUSTRALIAN FEMALE. STRAVA IS CRAPPY "COMPUTER-SOUNDING" MALE.

    0
    Comment actions Permalink
  • Same problem with voice changing to the old Stephen Hawking one.

    1. Can you confirm if you recently changed the settings for Siri?  NO

    2. Did you update your iPhone to iOS 12?   YES

    3. Can you confirm what version of Strava you are using?   v66.0.1  (13617)

    4. Can you let us know what language your phone is in and what language/accent Siri is set to?     English;  American (Female)

    0
    Comment actions Permalink
  • Echoing above.

     

    Latest IOS

    Latest Strava build

    No settings changed elsewhere

     

    Lame-o 8-bit male voice with terrible enunciation.  Not a partner, nor inspiring.

    0
    Comment actions Permalink
  • The support team opened a know issue article about this (https://support.strava.com/hc/en-us/articles/360016784131-Audio-Feedback-Changed-Voice-iPhone-iOS-12), follow it to receive any news about this issue.

    0
    Comment actions Permalink
  • I was able to get old voice back by going to settings-general- accessibility-voiceover-then under speech selecting Siri female US and under rotor languages selecting English US and Siri female for voice

    2
    Comment actions Permalink
  • I go back and forth between Strava on the iPhone and on the Apple Watch. When I use it on the phone, I get electronic robot voice, but when I use the watch, I get Siri voice, but only notifies on the full mile.

    0
    Comment actions Permalink
  • I found a temporary but great solution and I hope it helps some folks.

    In iPhone settings > general > Language and Region

    Change your Region to Australia or UK or try others to get a much better default voice. It changes the whole phone but worth it it bothering you. Australian is very clear female, British is a deep male... haven’t tried others.

    Same can be done for Apple Watch....

    Go to Apple Watch app, same settings change and the watch will reset in new region.

    HOPE THIS HELPS!

    0
    Comment actions Permalink
  • Damn. Can this be fixed??!!

    0
    Comment actions Permalink
  • I have Siri disabled, and had so with iOS 11. It worked on iOS 11, it should work on iOS 12. Ramp up your test efforts a bit, will ya?

    0
    Comment actions Permalink
  • I think it defaults to the first available voice in a language, instead of going for Siri voice first, as it should. And all iPhones now have "Fred", the 1991 robot voice and F comes before S. And no, you can't delete it.

    0
    Comment actions Permalink
  • > settings-general- accessibility-voiceover-then under speech
    > selecting Siri female US and under rotor languages selecting
    > English US and Siri female"

    Troy's work-around worked for me! Thanks!

    0
    Comment actions Permalink
  • update to 12.1! fixed it for me! finally!!!

    0
    Comment actions Permalink
  • try this site. Good voice changer online

    0
    Comment actions Permalink
  • It seems this also happened with iOS 13! Please fix it :-)

    1
    Comment actions Permalink
  • Yup, just did my first run after the iOS 13 upgrade and now have a British male voice making the announcements. He's probably pronouncing kilometre the proper way (I'm in Canada), but I'd love to get the lady back!

    0
    Comment actions Permalink
  • I found a temp solution:

    In Watch app on iPhone do this

    Go to General -> Language & Region -> Tick "Custom"

    Then choose "Watch Language" -> Select another language than your current.

    Then verify that the voice in Strava is actually changed.

    Then go back and choose "Watch Language" -> Select you preferred langauge back.

    This way I got Siri voice back in Strava!

    0
    Comment actions Permalink
  • Tried Thomas' workaround, and while manually changing the language to another region worked, changing it back did not. Seems part of the problem might also be what accents are associated with each language option.

    English (Australia) uses what (I assume) to be the correct voice, and English (US) uses the one I'm expecting to hear, but English (Canada) (which is my setting) uses the British voice.

    I guess I can just leave my settings at English (US) and have things work the way I want (in Strava, at least...who knows what else changing that setting will mess with!)

     

     

     

     

    0
    Comment actions Permalink
  • Hi Strava,

    I'm not getting an option to change voice audio cues after upgrading to iOS 13.2.2. Latest Strava App version is 124.0.0. I now have an American female with no option to change.

    Reading above comments, I'm wondering if this ever got solved?

    Thanks.

     

    0
    Comment actions Permalink

Please sign in to leave a comment.

Didn't find what you were looking for?

New post