How do I now set approval for new follower requests

I used to have the option in settings to have new followers request my approval. I can't see this option any more since the whole privacy interface was 'cleaned up' and a friend has asked how to do it. I'm on the free version so has this now been made a paid for option? I've read the articles in support section and reference is made to 'enhanced privacy' being enabled but no info on how to enable it......

0

Comments

14 comments
  • Found it now. Settings/Privacy Controls/Profile Page/Followers......

    -1
    Comment actions Permalink
  • Go to the setting page in your profile (mouse over your profile picture and select "settings" from the dropdown list). Select "privacy controls" from the left menu. There should be 4 main topics on the upper part of the page. The first one is "Profile Page". It is set to "Everyone" by default. Click on the down arrow and select "followers". This should restrict your profile page to just your followers and require you to approve any "follow" requests.

    0
    Comment actions Permalink
  • I have a follow request and can't figure out how to approve him and can't seem to find it in help and support.  I have the free version and have my privacy set to followers, but can't find a way to approve the person who wants to follow me.  Confused.

    0
    Comment actions Permalink
  • I can see his follow request, but if I click on it, it says "cancel request"  On the setting button next to the follow request, it just says Remove Follower, or Block Athlete.  There does not seem to be a way to approve this follower.  Can someone tell me how to approve a follow request on a free account?

    0
    Comment actions Permalink
  • Help says to turn on enhanced privacy.  Can't find a way to do that. 

     

    1
    Comment actions Permalink
  • @Susan, 

    Here's an article that explains enhanced privacy. Hope that helps! 

    1
    Comment actions Permalink
  • They haven’t made it easy to find now Susan. It’s in settings/privacy controls then in Profile Page section top left select ‘who can see’ to ‘followers’.

    0
    Comment actions Permalink
  • Remaining puzzle is: you get notification about someone requesting to follow you - and i'm frustrated for not being able to find a place to actually ACCEPT it. Link from the email "accept" does not lead to a page with options to accept.

    How hard can it be ???

    2
    Comment actions Permalink
  • Also can't find how to approve follow request. Is there a way?

     

    1
    Comment actions Permalink
  • I have the same issue, can't accept a follower.

    Does anyone have find the solution? Is frustrating...

    I have the free version

    0
    Comment actions Permalink
  • the same problem....

    0
    Comment actions Permalink
  • After uninstalling and reinstalling everything working fine, thanks Strava support

    0
    Comment actions Permalink
  • Where is the comment from Strava please - I have uninstalled and reinstalled and it still does not work

    Really frustrating!

    Problem - I cannot approve a request to follow

    I have set privacy settings to followers - as mentioned in this post

    I have removed and reinstalled the app

    No change

    Please help

     

    0
    Comment actions Permalink
  • I am using the web interface and having the same problem.  I received an e-mail saying someone wants to follow me, I click on the accept button, and it just goes to my profile page.  In the past there was a notification in strava where I could approve the request.  

    0
    Comment actions Permalink

Please sign in to leave a comment.

Didn't find what you were looking for?

New post