Total time not moving time

Can anyone tell me how to show total time elapsed on my feed rather than the moving time. I am a power walker an I use the run function rather than walk so I can see my splits but need to kow total time rather than moving as I have a target time.

5

Comments

9 comments
  • Strava doesn't allow you to do this.

    If you view your activity on the web (I'm not sure about the app), it will show you your elapsed time, though. As an ugly workaround, you can set the run type to "Race" and it will change the activity's time to the elapsed time, with the drawback that it now broadcasts to everyone that your walk was a race.

    3
    Comment actions Permalink
  • Thanks x I don’t mind if people think it’s a race 😉

    0
    Comment actions Permalink
  • Hi!

    I think a beautiful workaround shoud be just show "Total Time" besides "Moving Time" on STRAVA APP screen. I think knowing Total Time is relevant because some trails are so steep that we can not run but the clock is ticking! The effort is there!!! Is it dificult to implement?

    Thanks.

    MB

    4
    Comment actions Permalink
  • the moving time on my runs recently is totally wrong.  I'm running on a straight, flat path and my elapsed time for 1 km is 5:00, but Strava counts the moving time as only 4:00, which gives me a wildly inflated running pace.  How can I prevent this from happening?  I don't want to see my "moving time" or my "moving pace" if Strava can't calculate it correctly.  I know I can find this information by going to the pace analysis page, but on the main feed my run is broadcast with a ludicrously fast overall pace because Strava is just making stuff up.

    7
    Comment actions Permalink
  • James, what are you using to track your runs? Does it have a setting for auto-pause, and if so, at what pace is that set for? Some devices are set to auto-pause if you pace drops below a pre-set pace. If your moving pace is close to that, it could be auto-pausing periodically through your workout but then catching up on the distance when it realizes you are still moving while not counting the lost time.

    0
    Comment actions Permalink
  • Similar problem here... i use the strava phone app to record and use the web app for viewing. Moving time is often grossly inaccurate.

    Had some luck tho. I found that understanding pauses is the key. Somewhere in the Strava help text i came accross a sentence "... As long as your device is recording conventional pauses, Strava will respect any pauses recorded in the file whether your device pauses automatically or you manually hit the pause button. ...". If no pauses detected in the track, it insists on calculating moving time anyway based on type, usually poorly. No way to explicitly turn this off.

    Also, for 'run' activities, strava app uses the the accelerometer to detect pauses. For 'ride' activities, it uses gps position.

    For me, for hiking, where i do stop regularly, this works well for me...
    Record Activity/ Settings/Auto Pause/Run Auto-pause - Checked
    Note: helps to shake the phone once in a while to make sure its unpaused.

    For walks where i want moving time to be = elapsed time...
    Record Activity/ Settings/Auto Pause/Run Auto-pause - Un-Checked
    AND do at least one Stop/Resume

     

     

    1
    Comment actions Permalink
  • Forgot to mention... if you manually upload a gpx, or edit a track (crop, split, change type, etc), it seems to have lost all pause info and always does the inaccurate moving time calculation.

    0
    Comment actions Permalink
  • I just had a treadmill run where the pace shows up as 11:14/mi and the moving time shows up as 37:05. It shows up properly in training peaks and Garmin as 30:10 and 9:09/mi. Not sure how to fix this in Strava? Did something change in the last release/update since it worked properly a few days ago?

    Thanks

    0
    Comment actions Permalink
  • I have found this too, i have been doing 5 k run/walks before i stop it, i check the time and then when it saves it takes time off, i dont have auto pause on, i dont understand whats happening, its very frustrating.

    0
    Comment actions Permalink

Please sign in to leave a comment.

Didn't find what you were looking for?

New post