Samsung Gear S3 Error: wrong activation code entered Samsung Gear S3

I cannot get Strava to work on my Samsung Gear S3 watch. I get the error: wrong activation code entered. I have tried getting the code from my phone "wileyfox Swift 2 x" my wife's "Galaxy note 8" and my PC.


Has anyone overcome this problem?



  • Official comment

    Sorry for the trouble linking the Strava watch app with your Strava account. This appears to be a caching issue we are investigating. 

    As a temporary workaround, you can use an Incognito browser window to connect your accounts.

    Please submit a Support Request if you continue to have issues linking accounts.

    Comment actions Permalink
  • I am also receiving this error.  I had the app loaded on my gear 3, then reset the watch and now I am receiving the same error.  I too have tried from my android, on explorer and chrome just won't activate a code at all.  Any help with this would be fantastic. I am using Samsung health until I get it resolved.  


    Comment actions Permalink
  • I am also in this boat, the code is always wrong.And no response from Strava after 10 days is sad. The under Armour App seems to work fine om my Galaxy. Hate to have to leave Strava

    Comment actions Permalink
  • Tried the Incognito mode and Private in Firefox and no different result, same error message. Thanks for the help, I look forward to this issues resolution

    Comment actions Permalink
  • The above incognito mode answer worked this morning!
    Thank you Sean!

    Comment actions Permalink

Post is closed for comments.

Didn't find what you were looking for?

New post