The 1999 date issue is fixable by exporting the gpx and re-importing after making some changes

Hi all,

Like many, I've been experiencing the "1999 date issue". See https://support.strava.com/hc/en-us/articles/360026660091-Activity-Syncing-Issues-and-Incorrect-Start-Times-beginning-on-April-6th- for an official Strava update on this. 

In that post they mention they cannot fix the 1999 date. That's unfortunate if you want your stats to be accurately reflected. However, you can actually fix it as follows:

1. export the activity as a .gpx

2. open the file in a text editor

3. replace all occurences of the wrong 1999 date with the date on which you actually recorded the activity

4. (optionally also change the time although that's much more troublesome)

5. upload the changed gpx file

6. verify it now appears in your feed where you expect it to

7. delete the original

Hope that helps anyone.

0

Comments

6 comments
  • Buenas noches..

    1. exportar la actividad como .gpx    Comó se hace el exportar como .gpx?

     

    0
    Comment actions Permalink
  • A ton of work!  There's got to be a better way to fix this!!!

    1
    Comment actions Permalink
  • for a start how do you export the GPX? We are not all as advanced!?

    0
    Comment actions Permalink
  • Thanks, just managed to edit a run that was showing as 'Started in 2007' for the first 4 mins before getting a signal and showing the correct date, then worked backwards to edit all the times. Took a while but it was worth it to get my QOM logged properly!! :)

     

    0
    Comment actions Permalink
  • Can someone please explain how you export an activity as a gpx file?

    0
    Comment actions Permalink
  • #Leen De Brun when you complete recording and before synch n upload there must be extra options --> export. see the screen .

    0
    Comment actions Permalink

Please sign in to leave a comment.

Didn't find what you were looking for?

New post