Disable "Your friend just finished a ride" notifications

For the past couple of weeks my Strava Android app has been periodically pushing me notifications reading something like "Your friend [friend name] just finished a ride. Check it out." I don't want to receive these notifications - but there is no option to disable them in the Android app preferences.

I can't silence all app notifications at the Android system level because I want to retain the active recording info. But this is frustrating and a very bad practice by Strava. You should never have your app send notifications that aren't either (1) absolutely vital to the app's purpose or (2) easily disabled via a clear option in Settings.

Please fix! Thanks, Drew



10 comentarios
  • Comentario oficial

    Hi everyone,

    You can now disable this notification via the mobile app.. Go to your Settings > Notifications > scroll down to Friends section. You will see the option there to disable this notification. 

  • +1 I'd like to disable this too, but haven't found he setting to do so.

    (I'm on iOS though)

  • Same here on iOS. I tweeted at Strava support back in March and they were not aware of it as an issue. It seems unlikely we all hallucinated this so I'll tweet back at them with a link to this thread.

  • I was happy enough with the daily activity emails that Strava used to send, but now Strava has terminated that valuable optional feature and instead added these annoying, intrusive, unblockable notifications to my cell phone.  I'm glad to hear that Strava will soon be adding an option to turn them off, and I hope you hurry!  Thanks.

  • In the meantime, my new practice is to kill the Strava process whenever I'm done using it by clicking on Android Settings -> Applications -> Strava -> Force Stop.  Then I start it again when ready to ride.  But it will be much better when Strava itself adds the options to disable these unwanted ride notifications.

  • I am finding this frustrating as well, and would like to turn these off. Especially when it appears on my watch!

  • +1. Getting tempted to DISABLE ALL STRAVA NOTIFICATIONS (which I'm sure Strava Corp would prefer I not do) since I can't just turn this one off. Should not be hard to add an option to disable or, until that is rolled out, disable all notifications.

  • same here i'm experienceng this kind of issue... 

  • The solution posted here does not work. I’ve always had this notification turned off in the app, yet I still receive emails. So annoying!

  • I agree with Mark Grafton.  I have the setting disabled but I continue to get email notifications.

Iniciar sesión para dejar un comentario.

¿No encontró lo que buscaba?

Nueva publicación