Error computing Route when loading a GPX file

Hi. I've created a route in Garmin Basecamp and saved it as GPX. However, when I come to import it I get the "Error computing route" message. Some routes work and others don't. Anybody know how to fix this?

 

S

22

Comentarios

56 comentarios
  • Same problem here, also tried the above discribed work around without any success. I counted on this feature to make the Club Events more Fancy by immediately adding the GPX. Unfortunately, I can only give them a link to Routeyou, would have been nice though...

    0
    Acciones de comentarios Permalink
  • Hi Everyone, I'm following up with our engineering team and have created an internal report to track this issue. I'll keep everyone updated. 

    -1
    Acciones de comentarios Permalink
  •  

    That said, the builder is awful and horrific to use, so when plotting routes I prefer to use Google Maps and then import it into Strava.

    Yup, the route builder is a bit pants and a disaster if you want to edit something early on in route or add new points. I use RideWithGPS [the best of all the various map plotting tools I've tried], so I can have turn by turn directions on my Wahoo. But I need to plan some routes with Strava as I need to use the Veloviewer Strava plugin for Chrome for certain kinds of routes I do.

    0
    Acciones de comentarios Permalink
  • To be fair, as this feature is available to Standard members as well as Premium members we are not actually paying for this app. That said, it would be nice if it worked. Have you tried clearing your cache?

    0
    Acciones de comentarios Permalink
  • I'm having the same issues and another big +1 for a stable version integrated into the main product one day. Just had to spend 45 minutes manually creating a route from a GPX file of a 150mile ride that was created in another mapping tool and would not import.

    0
    Acciones de comentarios Permalink
  • I have the same problem.

    I've tried this more then 30 times the last half year, always the same problem: Error computing route.

    I can see the route on the map, but I can't save it.

     

    Please fix this!!!!

    1
    Acciones de comentarios Permalink
  • Re-posting the "solution" that worked for me. You have to upload and download your track on gpsies, but still simpler than recreating a route.

    0
    Acciones de comentarios Permalink
  • same issue here. let´s fix this!

    1
    Acciones de comentarios Permalink
  • Hi, 

    thanks for the response, unluckily it happens also when I use strava URLs.. 

    0
    Acciones de comentarios Permalink
  • This is still broken, even when using the gpsies method. I can even see the map after the upload, just can't save it. So frustrating!!!!!

    1
    Acciones de comentarios Permalink
  • I've given up on Strava for routing and tracking. I use RidewithGPS. Just use Strava for the community.

    1
    Acciones de comentarios Permalink
  • I used a simplified workflow based on that of Francis Saul.

    I created the initial route in bikemap.net, pushed through GPSies then right into Strava GPX import, and it worked. Now, at first it still throw an error during save, but worked the second try. (With the same GPX.)

    0
    Acciones de comentarios Permalink
  • Still not working properly. Put up some pressure in the development department.

    Thanks.

    0
    Acciones de comentarios Permalink
  • Ridiculous that this still does not work correctly. This is a very basic feature that Strava absolutely should prioritize. 

    5
    Acciones de comentarios Permalink
  • mid of April, no change to the error. gpsies trick also wouldn't work anymore :(

    1
    Acciones de comentarios Permalink
  • Still no way to upload gpx as route :((

    1
    Acciones de comentarios Permalink
  • I'm paying for premium. Why the heck doesn't this work already? I can load the same routes to RideWithGPS. I can do a heck of a lot cooler things with their ride editor and there are even club rides that can be saved and shared with members. Why can't Strava do more advanced things like this with my money? 

    2
    Acciones de comentarios Permalink
  • Two years have passed and nothing has happened. I think premium customers can expect a working routeplanner, like reverse route, import gpx, exclude gravel and so on. So please develop this further or build a coop with an already existing service. Most important are import gpx from other routplanners and reverse route.

    1
    Acciones de comentarios Permalink
  • I'm certainly not paying for premium until we get better routing features. I'll just pay RideWithGPS for now. 

    1
    Acciones de comentarios Permalink
  • 0
    Acciones de comentarios Permalink
  • I tried the alternative suggestion (top fixed post) by Ella Anderson. Regretful to say that also breaks. I get a ".....gpx is a duplicate of ..." which is incorrect because the perceived duplicate is a whole other route. 

    UPDATE: Removing old conversion duplicate makes me upload, but saving as/converting to route still does not work :(

    UPDATE2: Converted to TCX from gpsies. Uploading to strava (as docs say it's supported) it says "Unsupported file format" .. seriously :(

    UPDATE3: Tried all sorts of conversions. Garmin dashboard uploads without any problems, also conversion to course (route) works. Then download and upload to strava .. still failing :(

     UPDATE4: For using the route as navigation on my mobile phone next to my garmin 820 for logging my ride .. Upload your GPX to Google Maps and you got the route on your phone! ... regretful the only way

    Just noting all this to save others the trouble

    2 years down the road .. I'm still pretty happy with Strava ... However taking so long to enable a decent no hassle gpx upload for your customers is not done. If it was my company I would kick somebody's ass! .. This is customer perception .. most people here pay your friggin' salaries. Solve this stuf!

    PS I'm one of those paying customers.

    0
    Acciones de comentarios Permalink
  • It seems like this issue is just getting worse. Now I am getting this message for every second route I am trying to create from strava-recorded rides. Not only are they now not allowing to import external files, but they cannot even allow to effectively use their own stuff... 

    0
    Acciones de comentarios Permalink
  • Solution: This worked for me Converting All Trails GPX download to Strava Upload

    Sometimes, you need to add timestamps to GPX files. This need may arise if you're trying to import a course into your GPS. In order to be accepted as a course, it needs to have time stamps on some GPS models. Another possible reason is that if you want to use our combine tracks tool, time stamps are required. We use the time stamps to put the files in order (the order in which they occurred). Finally, you can use this tool to "recreate" an activity. You enter the start date/time, and then the average speed, and a moving track will be created for you.

    use this online app to add time codes and then you can have the onlone app upload directly to Strava for you

    https://gotoes.org/gotoes/strava/Add_Timestamps_To_GPX.php 

    Authorize UploadFromCombiner to connect to Strava

    UploadFromCombiner
    UploadFromCombiner 
    http://gotoes.org/strava

    This app will upload combined files directly to Strava

     

    UploadFromCombiner will be able to:
    •  Access your profile and activity data
    •  Upload activities for you and edit your profile

    You can revoke access to any application at any time from the Applications tab of your Athlete profile

    0
    Acciones de comentarios Permalink
  • I have no idea why anyone pays for premium with Strava. This feature has been beta for years now and gets this error all the time. Remove it or buy something that works. Just buy RideWithGPS and integrate that into Strava or something. 

    0
    Acciones de comentarios Permalink
  • @Dean Donnelly

     

    I tried using your tool to timestamp and upload to Strava .gpx routes but it still failed. Any ideas?

    0
    Acciones de comentarios Permalink
  • Confirmed that http://gotoes.org/strava app works. I added timestamps to gpx that was failing and uploaded directly to strava. It created an activity and I was able to create a route from that.

    0
    Acciones de comentarios Permalink

Iniciar sesión para dejar un comentario.

¿No encontró lo que buscaba?

Nueva publicación