Strava stops recording mid-ride

The version 38.0.0 for Android stops randomly recording while riding. This results to long straight lines with a large part of the ride missing.

15

Comentarios

58 comentarios
  • Thanks @Hendrik. I am also running OxygenOS 9 but can't seem to find the exact picks to "lock" an app. Can you please provide the detailed path to that setting/change? Cheers.

    0
    Acciones de comentarios Permalink
  • The update to Android 9 fixed it for me.

    0
    Acciones de comentarios Permalink
  • Fixed now for me. It is probably what someone posted above but it was never clear to me. This worked for me in Android 9,not sure if the options or clicks are the same in 8. Press the switch apps button (not sure formal name) in the navigation bar. It will show a scrollable set of "shrunk" apps. Find Strava and choose the (vertical) 3 dot menu (far upper right, actually above the shrunken app). Then hit the lock icon. I've google around extensively and can't even find out exactly what this selection does, but it definitely works for me.

    0
    Acciones de comentarios Permalink
  • No update with Oreo for p9.

    So that solution seems useless for me.

    0
    Acciones de comentarios Permalink
  • My solution had been to switch off the Display Sleep function by setting it at Never. This has worked but was always a bit of a nuisance. Yesterday, I forgot to do this but after 13 miles of the ride, I was surprised that Strava had recorded my ride correctly and hadn't stopped after a few minutes. I continued to the end of the ride and there were no problems. So maybe in my case something has been resolved either within Strava or through an Android update. I have though no idea which one.

    0
    Acciones de comentarios Permalink
  • Restarting the S8 and switching off the battery power save mode solved this problem for me.

     

    0
    Acciones de comentarios Permalink
  • I had a similar problem and here is how I fixed it.  I recently purchased a Unihertz Atom Android phone, running Oreo 8.1. Strava worked fine on my old Moto G4 running Nougat 7, but when I used my new phone the app would stop recording after a bout 5-15 minutes.

    It seems like this is caused a new battery saving feature of Oreo, but it does break some apps, especially third party apps that need to constantly query the GPS.

    I fixed my problem by going to Settings > Smart assistant > Power Save Manager > White List. I simply white-listed Strava to run in background.

    I don't know if all android Oreo phones have this feature or menu option. I tried to follow some of the instructions from the previous posts, but the menu options seem to be different from phone to phone.

    I also set my phone to developer mode and changed a few other battery saving settings as well, so I'm not 100 percent sure if this was in combination with of one of the other changes that I made that actually fixed it, but I do know that it started working after I whitelisted Strava.

    0
    Acciones de comentarios Permalink
  • Well after excitement over a working fix, a minor OS upgrade (Oxygen OS 9.0.4 from either 9.0.2 or 9.0.1) I'm back to the worst off I've ever been. Strava consistently stops recording after some small number of minutes. I really hate carrying 2 phones just for Strava...

    0
    Acciones de comentarios Permalink
  • @Mojo Marshall
    I solved a problem with using Sportstracker and then export file and import it to strava.
    No problems for me at all.

    0
    Acciones de comentarios Permalink
  • 0
    Acciones de comentarios Permalink
  • Thanks @Kl3m3n M. Didn't work for me. I even had it not optimize battery and locked the app. Lasts barely any time at all before crapping out.

    0
    Acciones de comentarios Permalink
  • For me. My fix was for an android I went

    Settings > Apps > Advanced > ignore system optimisation > Allowed ( grey arrow in the top corner > All apps > Find Strava > Allow.

    Also did the same with ignore battery optimisation.

    This solved my problem of Strava keep cutting out.

    0
    Acciones de comentarios Permalink
  • Thanks @David P. Unfortunately my version of Android (OnePlus OxygenOS 9, very close to stock Google Android 9) does not have system optimization, only battery

    0
    Acciones de comentarios Permalink
  • I have it too. At first rarely. Now almost every ride. Motorola G5

    0
    Acciones de comentarios Permalink
  • Use other app and then import .gpx file into strava, problem fixed

    0
    Acciones de comentarios Permalink
  • I thought that was the solution but yesterday I was recording using Ride with GPS and I had a similar problem. The route stopped and restarted twice with the plot shown as a straight line between the interrupt points.

    0
    Acciones de comentarios Permalink
  • I've had similar problems with that or other route recorders. I think it may be a hardware problem.

    0
    Acciones de comentarios Permalink
  • My wife stops recording when phone is asleep Turned wifi off and it solved the problem happy days.

    0
    Acciones de comentarios Permalink
  • Ste Woodward - that's an interesting solution which I don't think has been mentioned before. Are you willing to tell us the phone model and operating system hat this worked on?

    -1
    Acciones de comentarios Permalink
  • ONCE AGAIN.
    Use SPORTSTRACKER and then upload activity into Strava via web page.
    The same for exporting .gpx file from Sportstracker.
    No problem att all.
    STRAVA has issues with Huawei and there is a big blow for Strava developers not to solve issues with recording

    0
    Acciones de comentarios Permalink
  • It was mentioned on mapmyride, there having the same problem, turning wifi off worked for us on a Samsung s8

    0
    Acciones de comentarios Permalink
  • Having the same problem on Huawey P10 Mate Lite. Really frustrating losing half of the ride..

    0
    Acciones de comentarios Permalink
  • FIX (at least on latest Samsung  phones; I have a 10+) for Locking, GPS Loss, Ride Loss, a host of other snags.

    The short of it is that Samsung is putting the app to sleep. As a software developer seems like the answer at the Strava end is the keep the app in some kind of battery draining, "always on" mode til you tell it other wise, but that's on them. For us we have a  couple of options. Change the battery mode to performance mode (search it in settings). That keeps anything from going to sleep. That does suck for overall battery life. The better fix that I regret I have found exactly only twice (it is not intuitively placed) is to find the battery optimized list of apps, and uncheck Strava. This works like gold. I have not had a hic-up since.

    0
    Acciones de comentarios Permalink
  • Sports Tracker does not work for me. It and Strava are both locked and all power/battery management ix disabled. Exactly the same problem with Sports Tracker as Strava.

    0
    Acciones de comentarios Permalink
  • Update. Finally got a new OnePlus 7 Pro. Problem completely gone.

    0
    Acciones de comentarios Permalink
  • Cancel that just above. Problem is back on the new phone with the very latest Android version. This is ridiculous.

    0
    Acciones de comentarios Permalink
  • Tired of bad app. I went back to RideWithGPS. Never fails. Bye Strava.

    0
    Acciones de comentarios Permalink
  • I'm having the same problem that so many other users are reporting.  Strava unexpectedly quits in the middle of long bicycle rides.  It's an intermittent problem.  Android (Samsung 8).  I tried changing the Power Mode for the battery, but that didn't solve the problem.  Since this is a problem for so many users, I would hope that Strava tries to solve it.

     

    0
    Acciones de comentarios Permalink

Iniciar sesión para dejar un comentario.

¿No encontró lo que buscaba?

Nueva publicación