Segments not syncing with Garmin Edge 1000

Hi, I have been having problems with strava segments ever since becoming a premium member a few months ago.

Bottom line is: ever since I became a premium member I have never been able to get my strava segments onto my device:

These are the steps I have taken so far:

- spoken with Garmin support (still no luck and the issue is still open with them) - this has included them replacing my original Edge 1000 with a replacement

- tried unstarring and un-linking strava and garmin and re-doing the whole process (countless times)

- syncing the device through Garmin express on 4 different computers (both Windows and PCs)

-sending log files to Garmin on multiple occasions

Does anyone have any other ideas/suggestions?



4 commentaires
  • Commentaire officiel

    I'm sorry about this James. I see you have just created a ticket a few minutes ago - we will respond shortly.

    I apologize for the confusion, however since our community discussions focus on product feedback we cannot guarantee a reply for each post. 

    If you need technical assistance or troubleshooting, please reach out to us directly. 

    Actions pour les commentaires Permalien
  • Dear Support,

    It has been nearly 2 months since I have sent my initial request, please can you respond?


    Actions pour les commentaires Permalien
  • I have exactly the same issue and I would love to get an answer from Strava people !





    Actions pour les commentaires Permalien
  • Hi Marc,
    It took me a very long time to get to the bottom of this with both strava and Garmin (many months!) so let me explain to you what the problem was for me:

    It turns out that since i had my settings in strava set so that all of my activities were marked as private automatically it was messing things up. What you need to do is make sure that before you create a segment, the activty you create it from is NOT marked private. Then you can create your segment (doesn't matter if it's a public or private segment), once you have done this i found it finally worked for me. It was a huge pain for me that i had all of my segments already made so i had to re-create all of my segments from scratch and delete the ones I had already made.

    I hope this helps! Best of luck


    Actions pour les commentaires Permalien

Vous devez vous connecter pour laisser un commentaire.

Ce n’est pas ce que vous cherchez ?

Nouvelle publication Agent Only: Button marked