Samsung Galaxy Watch 46mm - Strava doesn't use gps

I installed Strava last week on my Cubot King Kong 3 phone, that has Android 8.1.0 and works fine. And I was also able to install the Strava app on my Samsung Galaxy Watch 46mm and I got I working.

I installed it on my watch on April 24th and the last activity it recorded was on April 26th. After that date no activity is recorded.

I checked GPS settings on the watch, was active. I did a software reset first trying to fix it. Didn't work. Tried a hard reset. Didn't work. When I start the Strava app on the watch I notice that the gps icon is greyed out, when I start an activity (outdoor walk) it only records time and heartbeat and when I want to save it shows "Strava needs a longer activity to upload. Do you want to discard this one?".

Tested GPS with a gps tool and I saw coordinates. So gps is working.

Any ideas how to fix this. Or is the Strava app for Samsung Galaxy watch buggy?

Regards

Update: It is even getting more strange. I had an activity started on april 30th, outside walk, no gps was there, and no walking time. When I picked my phone this morning I noticed Strava added an activity which was showing the route and time I walked.

 

10

Commentaires

38 commentaires
  • I recently bought a Samsung galaxy watch & I was facing the same issue. 

    As a workaround, I switched off the Bluetooth on my phone before starting the Strava activity on my galaxy watch. With this, I have no problem in recording the session using the watch's GPS.

    Post workout I can launch the strava on my phone & sync the data manually.

    1
    Actions pour les commentaires Permalien
  • Hi Guys,

     S-Health is a little bit annoying when one uses another tracking apps. Try to disable It, Strava apps will work better. You can also try the Run4Gear app it is also compatible with Strava. It may solve your problem.

    Have nice run, Galaxy Watch is great for running

    0
    Actions pour les commentaires Permalien
  • Hi guys, I found a solution by luck. Last sunday, I had a competition and when I tried to use Strava in my Samsung Galaxy Watch Active, the GPS didn't work (I wasn't with my phone - Samsumg S10+). Since the race had already begun, I opened S-Health and started an activity there (with Strava still working). After the run (I stopped the activity in S-Heath), I checked Strava in the watch and was still working. Surprisingly, all the GPS data was there. I don't know how, but Strava worked thanks to S-Health.

    I hope this help

    0
    Actions pour les commentaires Permalien
  • Bernhard's solution worked straight away, deactivate the bluetooth on your smartphone, open the strava app on your smartwatch and withing secs the GPS signal will become active.

    Thanks

    Tasos

    1
    Actions pour les commentaires Permalien
  • FOUND THE SOLUTION!!

    Mine used to work fine until at some point the GPS stopped working all of sudden. I tried reinstall etc but no change until I did this! Try it!

    On the watch,
    Go to Settings>Apps>permissions> go all the way down the list you will see System apps> Map control > turn on Locations.

    Then make sure you have GPS turned on on your watch

    Open strava app and wait for a minute. It will give you a light vibration once it connects to GPS.

    1
    Actions pour les commentaires Permalien
  • Hi Celina,
    Thank you so much, your solution is perfectly working for me. Now I don't have to do the drama of turning off Bluetooth.

    0
    Actions pour les commentaires Permalien
  • Hi - Just reading the comments above re this frustrating issue. Bernhards solution seems to work - I get Strava working on the Watch (Galaxy 46mm) if I switch off the phone bluetooth (Galaxy S10). Launching Strava on the watch then picks up the GPS and off we go, records pace, distance and time. Rather annoying to have to do this though and it used to work fine without, but good we have a solution - thanks Bernhard

    I then saw Celinas suggestion and tried this - but this didn't seem to work for me despite the GPS being on, Strava only records the time (no pace or distance)...arrrrghhhh

     

     

     

    0
    Actions pour les commentaires Permalien
  • This is still a problem on the brand new Galaxy Watch3. No solution provided here worked for me. Tried a factory reset on the watch, toggling location, permissions, system apps, waiting outside for signal, toggling Bluetooth, app reinstalls. Nothing worked. I will be using Samsung Health linked to my Strava as a workaround, that thankfully works.

    0
    Actions pour les commentaires Permalien

Vous devez vous connecter pour laisser un commentaire.

Ce n’est pas ce que vous cherchez ?

Nouvelle publication