route line keeps going out to random point

Hello!

Starting in November 2019 I started to notice the route line going out to a random point and then back again, like in my attached hiking route sample:

It's been happening more and more frequently, and now it happens on about 4 out of 5 activities (hiking and cycling). Why is this? Did something at Strava change?

Is it my phone? I use a Samsung Galaxy S10e which I started using in May 2019. My previous phone was an LG G6, which never had this issue. I've recalibrated my compass in google maps several times. I've also disabled app power saving for Strava. Any other ideas on why this is happening or how to fix it?

Thanks!

20

Commentaires

32 commentaires
  • hm, mee too, but i thought it's the phone
    Now i'm thinking to install old starava app version

    This likely happens when your gps looses signal but you still get approximation from cellphone network, which is that much inaccurate. 
    But starva app should catch the errors and see that you cant go 500m within 1 second...

    6
    Actions pour les commentaires Permalien
  • I've noticed the same in my activities as well as those of my family and friends and I've had them comment on how frustrated they are.  It only happens on bike rides when I stop but it's very aggravating.  Must be something that Strava has changed on there end because it never used to happen.

    0
    Actions pour les commentaires Permalien
  • I have had it happen on at least 50% of my recently recorded activities.  Here is one of the latest:             It recorded my top speed as 165mph.  Anybody got any ideas on how to prevent this?

    6
    Actions pour les commentaires Permalien
  • Same problem for me starting in Nov/Dec 2019, Been using Strava for years with Android phones. Current is Galaxy S9. Also use IPBike app which is amazing for customizing screens and in depth analysis. Heart rate strap data also. It uploads to Strava if you want. I get random out and back straight lines in Strava also. Perhaps 25% of the time. Causes big distance, speed etc errors.

    I now cannot trust Strava alone so I always use IP Bike at the same time. In Strava I must make all activity uploads private and then look at the activity track. If it is screwed up, I then upload the IP Bike track (you could use any app that will upload to Strava), make it public and delete the screwed up Strava track.

    Ridiculous!!! Someone needs to respond to this major issue. They even have it hardcoded into the "problem with your data" tab.

    1
    Actions pour les commentaires Permalien
  • Pixel 4 Android 10, same issue that just started recently.

    I already have battery optimization off for starva and it is allowed to access the location, so not sure what else to try.

    4
    Actions pour les commentaires Permalien
  • HTC U11, just the same situation. It does not happen constantly but destroys my stats from time to time.

    1
    Actions pour les commentaires Permalien
  • I would agree with OP that I have seen this beginning around Nov 2019 and it has been nothing short of frustrating. I have verified settings and toggled settings with no change. I mostly mountain bike so see it there the most, but it also occurs cruising around home and also hiking. If no fix, is there a location within Strava to go back in revisions until all is good again? - I will add this is with two Samsung S10 devices and one Note 10+ device.

    4
    Actions pour les commentaires Permalien
  • Try IPBike for tracking. Complicated to set up but every metric you can think of is available. Ant+ or bluetooth for all sensors. You can set up any activity as a named bike. It uploads to all common apps. Strava, Runalyze(great for analysis and free),etc.Try it out and after about a month you pay about $10 lifetime. Updated frequently. I've used for 8 years.

    0
    Actions pour les commentaires Permalien
  • Same problem here. Every time I pause an activity and continue, the GPS track is all over the place. Completely useless that way. How difficult is it to remove GPS data that is clearly wrong? Should be an easy job for Strava devs to fix this.

    2
    Actions pour les commentaires Permalien
  • Same here.  Issue started happening about a month ago, to everyone in the family.  Pixel 3XL, Pixel 3 and Samsung 10.  App on latest 147.10 version.

    1
    Actions pour les commentaires Permalien
  • I've been having the same problem since updating the Strava app on April 24th on a Pixel 3 running Android 10.

    0
    Actions pour les commentaires Permalien
  • I'm having the same problems with random straight lines when using my phone.
    Only recently started.
    I used my tablet today and that was fine but not something I want to take on every outing.

    0
    Actions pour les commentaires Permalien
  • I have exactly the same problem.  Mine started on Friday and it is with walking and running.

    My phone is a Samsung S10+.  My daughter has in i-phone X and my partner has a Samsung X Cover -  their phones track pretty much identical routes and are accurate.  It is only mine that completely throws the data. 

    We all only downloaded the app recently (last couple of weeks).  Prior to this, my daughter and I just used our equestrian tracker (Equilab) for our walks.  Equilab is very accurate but obviously doesn't give the right data for walk or running - just for riding and horse stats.

    I have tried all the 'fixes' as recommended - reset permissions/settings I have even downloaded the GPS tracker app which Strava suggests, but to no avail.

    What can be done????

    1
    Actions pour les commentaires Permalien
  • Same issue here on both my phone and my wifes phone

     

    Pixel 3 and 3a 

     

    very frustrating

    0
    Actions pour les commentaires Permalien
  • Having the same problem with recording bike trails on my Samsung S9, last summer was fine, now when I stop to take a pause, I pretty much always get the straight lines in it. Annoying!

    0
    Actions pour les commentaires Permalien
  • I'm experiencing the same problem, using a Galaxy s10e, last year everything was fine now I'm getting random lines going out into no man's land.. I can't figure out if it's to do with manualy pausing during a ride, It pretty much happens every time I record. Very annoying.

    0
    Actions pour les commentaires Permalien
  • I use my LG K8 android mobile phone.
    I'm sure I never had the problem before.
    However a month ago the random straight lines started occurring.
    I made various enquiries but to no avail.
    I then phoned my network provider and by chance spoke to a guy who uses Strava.
    He explained that on Android you have to have your mobile data on for it to work properly.
    It had always been off.  He also suggested clearing the cache by going into settings and the app on the phone.
    Since doing this + turning location off and back on before starting + turning Wifi off it has worked fine.
    Hope this is of some help.

    2
    Actions pour les commentaires Permalien
  • I have been experiencing the same issue in the last few weeks. I have used strava for years and never had a problem. Strava need to sort this out.

    0
    Actions pour les commentaires Permalien
  • I am having this problem too. Same phone as before, so as others have suggested, it implies a recent change on Strava's end. 

    Using an iPhone X.

    0
    Actions pour les commentaires Permalien
  • Having the same issue on about half of my rides.

     

    0
    Actions pour les commentaires Permalien
  • I am having the same problem. Never used to happen and now happens on almost all my rides. Started happenng on my samsung so. Just upgrade to s20 and still happens.

    0
    Actions pour les commentaires Permalien
  • Yep same for me, is there a fix?

    Phone is a Galaxy S20+

    0
    Actions pour les commentaires Permalien
  • I think Matt Clarke may have come up with a fix - at least for me and my Samsung Galaxy S8 Active.  I was having the problem occur at least every other timer I used Strava or even as often as 3 out of 4 times I used the app.  After reading Matt's comment above (posted May 22), I tried what he tried and the five times I've used the app over the past week and a half since making the settings change Matt mentions.  It seems to be working fine now (Knock on Wood).  So far so good! Thanks Matt

    1
    Actions pour les commentaires Permalien
  • @Matt Clarke, thx for your advice. what do you mean by clearing the cache on your phone? or was the trick just to turn wifi off, make sure mobile data is on, and disable the enable location before ride?

    0
    Actions pour les commentaires Permalien
  • On your phone go to settings, general and click apps.
    Go to the Strava App then Storage.
    In Storage click - Clear Cache.
    Takes half a minute.
    You need to do the other things you mentioned.
    NB: I don't have a clue why this works.  Its just what the techy suggested when I phoned my mobile provider.
    It maybe that just ensuring mobile data is on and disabling then enabling location would work.
    Just a question of trial and error.
    I'm just being belt and braces as it was driving me mad.
    Now works so that's what I'll do everytime.
    Good luck.

    0
    Actions pour les commentaires Permalien
  • If you clear your strava app storage cache, does it delete your past ride history?

    0
    Actions pour les commentaires Permalien
  • I've been having this same problem, everything was fine back in 2019 and then at some point it started happening.  FWIW I resorted to recording my rides with the Wahoo app which then syncs to strava.  If I record the same ride with Wahoo and Strava, only the Strava data is messed up. It has grown frustrating because I'm paying for Strava to use Beacon, but have to record my ride with Wahoo as well to get accurate data. Had the issue first on my OnePlus 6t and then got a OnePlus 7 and the issue exists on that phone as well.

    0
    Actions pour les commentaires Permalien
  • Strava leadership - if you want people to pay for your software, fix these basic issues.

    1
    Actions pour les commentaires Permalien
  • Actually I have wifi on too. Will check after turning wifi off.

    0
    Actions pour les commentaires Permalien
  • I’ve got the same issue on iPhone 11, so it clearly isn’t an Android or Apple issue. It happens on about 80% of my routes now, which is making them look ridiculous. It happens when I’m on WiFi or mobile data and It only seems to happen after I’ve finished my activity though and uploaded it.
    I certainly won’t be upgrading to premium if this is happening 🤦🏼‍♂️

    0
    Actions pour les commentaires Permalien

Vous devez vous connecter pour laisser un commentaire.

Ce n’est pas ce que vous cherchez ?

Nouvelle publication