Android Wear GPS not working anymore

I have a Ticwatch S2 which I use to track my bike commute synced to my Oneplus 7t. It has been working fine since I bought the watch about two months ago. But now the last few days I cant get the Strava wear app to get a GPS connection on its own. The pin turns white for the first few seconds on launch to then go grey agin, probably just a start up behaviour and not that the app actually has any connection here. 

The only way for it to get connection is if I also launch the Strava app on the phone, then the Wear app quickly receives a signal, but if I set the phone app in the background, or turn off the display the GPS signal on the Wear quickly goes away.

  • I have tried with the stock health app on the phone, and also Google Maps, no trouble here receiving a signal. So there's no problem with the devices. 
  • I have uninstalled both the Strava Wear app and the phone app, with no success.
  • I've looked over all the app permissions and inactivated battery optimize.

I believe I've tried all the methods I've found in other discussions. Can Strava please adress this issue? Or does someone here have a solution that tackles this problem in another way than the ones mentioned above?






1 commento
  • I suddenly had the same issue for my Fossil Sport. Worked for me to just uninstall and reinstall on the watch. But I hope Strava can show some love for the Wear OS app soon

    Azioni per commenti Permalink

Accedi per aggiungere un commento.

Non hai trovato quello che cercavi?

Nuovo post