Error computing Route when loading a GPX file

Hi. I've created a route in Garmin Basecamp and saved it as GPX. However, when I come to import it I get the "Error computing route" message. Some routes work and others don't. Anybody know how to fix this?





  • 正式なコメント

    Thanks everyone, 

    The GPX to Route import tool as mentioned here is still in beta and isn't being developed currently. When GPS data is imported via GPX using this tool, and it doesn't match Strava's known database of routes, you may see this error. This is something we're aware of. This issue occurs because we "match" new routes to our basemap of previously mapped data. We are continuously working with our Global Heatmap data to add new data to our basemap. 

    There is another option posted to Bike Forums you can try, which basically uses the Activity > Route tool that is in production instead of the beta GPX > Route tool that is not in production. 

    We hope we can improve this experience in the future, so continue to leave us your feedback here. 

  • Wow Dmitri V., that worked a treat. I might have a dig through the GPX later and see what needs manually changing, but I have built my first route from another GPX! To quote Sheik24:

    Hi-dee-ho everyone. As many of us know, century rides and the like frequently post .GPX versions of their routes so that those with GPS units can load them up and follow them on ride day. If you want to do this with Strava, though, you'll find that the app won't accept these files. You either have to build your own route, or actually ride the route, then save the activity as a route. Importing the GPX file as an activity won't work, as it doesn't have time stamps. So here's how to bend the app to your will:

    1.) Export the GPX to somewhere. Your desktop is fine.

    2.) Upload it to Strecke erstellen | GPSies. It will automatically put in time info (it assumes you went 10 mph. Whatever.)

    3.) Export the GPX Track (not route) to somewhere. Your desktop is fine.

    4.) Upload it on as an activity.

    5.) Save the activity as a route.

    6.) Delete the activity.

  • I have this problem too. What is even crazier is if I export a route I have manually made via the route builder and try and reimport it I still get the "Error computing route" message. The most frustrating thing is that I can see the route loaded on the map in the route builder, so it has obviously "loaded it".

  • Ridiculous that this still does not work correctly. This is a very basic feature that Strava absolutely should prioritize. 

  • I now have this with every GPX I try to upload. It's a real pity as up to a few months ago I never had any issues and it was really useful tool.

  • I'm having the same problem.

  • Yep, every damn .gpx file... 

  • Try the workaround described here:

    Worked for me. Involves creating a fake activity from GPX with some dummy time data, then converting that to a route, and deleting the fake activity.

  • i'm having the same issue with most gpx files created by I'm trail running, and never on roads. RideWithGPS route planner works much better, at least for trials.

    Also, he time of day doesn't see to affect whether it works or not.

    Still a great app


  • For those having issues with the Strava manual builder, clear your cache, close all active Strava tabs, close your browser and reopen. The manual builder should start working again.

    That said, the builder is awful and horrific to use, so when plotting routes I prefer to use Google Maps and then import it into Strava. There are steps stated before, however a full Google Map to Strava Workflow is as follows:

    1) Build directions with multiple stops in Google Maps.

    2) Copy the final URL and paste into (follow instructions at

    3) Convert and save the GPX to your desktop.

    4) Upload it to Strecke erstellen | GPSies. It will automatically put in time info (it assumes you went 10 mph. Whatever.)

    5) Export the GPX Track (not route) to somewhere. Your desktop is fine.

    6) Upload it on as an activity.

    7) Save the activity as a route.

    8) Delete the activity (it is generally the oldest activity at

  • I'm paying for premium. Why the heck doesn't this work already? I can load the same routes to RideWithGPS. I can do a heck of a lot cooler things with their ride editor and there are even club rides that can be saved and shared with members. Why can't Strava do more advanced things like this with my money? 

  • Shaun,

    I live in Europe and I noticed that almost every time the GPX fails is in the evening. If I try again in the morning it usually works, so there is probably no fault in your GPX either, particularly if other club riders have no problems.

    Regarding the avoidance of a Garmin device, I've just returned from France and many times my Samsung Galaxy S5 lost satellite signal resulting in a few off-routes and incorrect logging. I live in Holland so signal is not a problem (no hills!) but I'll definitely be investing is another device (Garmin or other) that has a stronger receiver.

  • Same problem for me. Initially the route builder worked fine, but since mid-March or so, I haven't been able to convert a single GPX file to a route. 

  • It seems like this tool is completely broken now. I get an error every time.

    Are there any plans for a stable/improved/fixed version? Eventually I think it would be great if this tool would graduate from Labs and become a built-in Strava feature. It's really a missing part of the experience. As a paying user I would really welcome this.

  • It's amazing how such a useful part of training, i.e planning a route, is so broken. is broken for me too

  • @ Francis Saul @ Dmitri V. 

    Unfortunately still not working :(

  • Just so you know - I get this error even when I try to convert strava activities publicly available on strava! This is ridiculous! 

  • Same issue here. I had one GPX file uploaded yesterday, which worked. All files thereafter have failed uploading with the same error. Tried everything; other times of the day, other browser and the above gpsies route, nothing worked. Strava, please fix this.

  • I am having the same error for every route i try to upload. Surely if we are paying to use an app things like this should work! otherwise what is the point in having it?

  • I have the same problem.

    I've tried this more then 30 times the last half year, always the same problem: Error computing route.

    I can see the route on the map, but I can't save it.


    Please fix this!!!!

  • same issue here. let´s fix this!

  • This is still broken, even when using the gpsies method. I can even see the map after the upload, just can't save it. So frustrating!!!!!

  • I've given up on Strava for routing and tracking. I use RidewithGPS. Just use Strava for the community.

  • mid of April, no change to the error. gpsies trick also wouldn't work anymore :(

  • Still no way to upload gpx as route :((

  • Two years have passed and nothing has happened. I think premium customers can expect a working routeplanner, like reverse route, import gpx, exclude gravel and so on. So please develop this further or build a coop with an already existing service. Most important are import gpx from other routplanners and reverse route.

  • I'm certainly not paying for premium until we get better routing features. I'll just pay RideWithGPS for now. 

  • Hi Scott,

    Unfortunately, since this is a Labs project, there will sometimes be errors with uploading.  It's possible there's something in the GPX file created in Garmin that Route Builder is not registering.  Please feel free to contact our support department and send along details and the gpx file.  

    If you are able to get the route uploaded and there are errors on the route, use the tool below to help us make improvements to Route Builder.

    • Go to the Route Builder and report the problem using the error reporting tool (represented by a small pin icon with an exclamation point in the bottom left corner of the Route Builder).
    • You can specify the exact point on the map where you see a problem and share additional information about the specific problem you found.

    We'll use those error reports to improve our basemap in quarterly updates.

  • I've just tried the same file again and it loaded fine so I guess it must just be an upload problem / glitch. If I have a problem in the future I'll just wait a wee while.

    Regarding the error reporting tool, that's quite useful 'cause already I've noticed the Strava route doesn't use some roads that are ok in OpenStreetMap (and the real world).

  • I have the same issue with some gpx files. Is there any way to work out what in the gpx file is causing the issues? I've gone through those line by line and cannot spot the differences between a working and non working file. 

    Real pity as they are club rides and I use Stava Routes for directions to avoid a Garmin device.