First time on segment, no placement on leaderboard

I went on a ride yesterday (March 31) and racked up a lot of segments on which I traveled for the first time (at least Strava-wise). In the past, the time I got would be placed on the All-Time, This Year, Men (in this case), and I'm Following leaderboards. On checking my stats for this ride, the top of the leaderboard on these first-time segment reads Your PR N/A, and the place ranking (the fraction) reads " - / 900" (for example). Even on segments where I got a PR on a ride, my previous PR time and ranking based on that time still displays.

 

I checked the settings for my ride, it is not set to private or has its segments hidden from the leaderboard. Is this a coding issue with Strava? On a ride I did on March 18, everything worked normally.

6

댓글

  • My case was similar, but in running. I starred a segment back in December 2017 and today I run that starred segment and the activity was not update to the starred segment. I lodge service ticket to Strava to investigate, I suggest you do the same. I am not sure if you need to be a premium member to lodge a SR or not.

    0
    댓글 작업 고유 링크
  • Did you try to recalculate segment efforts?

    • Open activity
    • click tool button
    • select last option (recalculate)

    That may help. At least it helped me.

    -1
    댓글 작업 고유 링크
  • No, your ride was probably flagged. Users can do this if the effort seems way out. Strava will then check into your data and clarify if its legit or not.

    0
    댓글 작업 고유 링크
  • You could try the "refresh my stats" option when you are looking at the segment.  Look on the right side under the little cog (settings) button.  It could be flagged as well as Andre mentioned, but you should be able to see that from your dashboard and probably would get a notification as well.

    0
    댓글 작업 고유 링크
  • The same thing happened to me, but then I realised that I had ticked the box "Hide from Segment and Challenge Leaderboards". So it was my mistake and Strava was doing as I had instructed it to. When I unticked that box I appeared on the leaderboard as expected.

    1
    댓글 작업 고유 링크
  • I have this happen quite often. Nothing seems to help. Double checked the hide from leaderboard tick. Sometimes I tick it, to later remove it again hoping it'd help. Recalculating didn't do anything either. There's nothing I can do to get this fixed for some of my activities :(.

    2
    댓글 작업 고유 링크
  • I face the same issue. I can see medals and trophies I got on the segment, but can't see myself in leaderboard.

    3
    댓글 작업 고유 링크
  • Same thing has happened to me. Strava, What can be done to fix this?

    0
    댓글 작업 고유 링크
  • same here. Cant find myself in the  leaderboard. No rankings available.  

    0
    댓글 작업 고유 링크
  • Same thing has happened to me on my last 2 rides - I’ve not changed anything in settings so have no idea why this has happened. I’m hoping it’s a blip or all my future efforts will not be on the leaderboard and that will be disappointing

    0
    댓글 작업 고유 링크
  • Same here - refresh / recalculate does not work for me

    0
    댓글 작업 고유 링크
  • Same here. Last 2 activities. I know I should be in top10 on a segment but not showing. Looks like a strava bug?

    0
    댓글 작업 고유 링크
  • Hi Folks, 

    I'm not sure if this is related to our updated privacy settings. If, after updating your privacy settings, you're still not seeing yourself on Leaderboards, please reach out to our team here.

    Cheers! 

    0
    댓글 작업 고유 링크
  • All privacy settings look fine. Still not showing up on any segments.  Will contact support.

    0
    댓글 작업 고유 링크
  • Same problem here, i contacted your support!

     

    0
    댓글 작업 고유 링크
  • I solved the problem! You have to change who can view your rider to 'everyone'. Job done!

     

    1
    댓글 작업 고유 링크
  • Go into a ride/run press the three dots in the top right hand corner press edit then change privacy to everyone

    1
    댓글 작업 고유 링크
  • I checked all these suggestions - still doesn't work.  One possibility:  I selected Backcountry Ski as the activity and Strava labeled my activity a Run (my default).  I saved it, the activity was flagged (too fast?!).  The option under resolving a Flag called "change activity" was unresponsive, so I used the Edit option (upper right on my phone) to change the activity to Backcountry Ski.  That removed the flag, but my time still doesn't appear on the leader board. Bug? 

    0
    댓글 작업 고유 링크
  • Paul - Are there even segments for "Backcountry Ski"?  I know there are segments for "Nordic Ski".  When you are looking at a specific "segment", what activity is it assigned to?  Is it a bike segment, backcountry ski segments, Nordic ski segment, running segment?  There is no crossover between the different activities and segments, so just because there is a segment for biking or running doesn't mean there is one for another type of activity like backcountry skiing or Nordic skiing unless someone has specifically made one for it.  

    0
    댓글 작업 고유 링크
  • "Backcountry Ski" is among the activity options that show up on my phone along with bike, run, walk, Nordic Ski, etc. when I am saving an activity.  When I saved that activity, segments appear for it (the leaderboard makes sense to me - I know a lot of the people listed on it).  The first segment I looked at showed my place as -/507 and the other segments were similar (my place on the leader board shows as "-" (have I been tagged as a Russian athlete and banned from all international competition including Stava?? :). I've never seen that on the run, bike, and walk activities I have recorded in the past.

    0
    댓글 작업 고유 링크
  • Strange.  Sounds like it should be working.  I would suggest submitting a request to Strava to look into it.  You can do that by clicking on the link in the bottom center of this page.  That will get to a Strava technician who can give you the most direct answer.  Would be interested to hear the outcome if you get a response from them.  Good luck.

    0
    댓글 작업 고유 링크
  • I FOUND THE ISSUE;
    If you RECORDED the exercise with the privacy settings set as “only followers/you” then it will never appear on the leaderboard. However once it is turned on and you run/ride again then it will appear. I know it sucks but try your hardest to beat your time again!

    0
    댓글 작업 고유 링크

댓글을 남기려면 로그인하세요.

원하는 것을 찾지 못하셨나요?

새 게시물