Strava stops recording mid-ride

The version 38.0.0 for Android stops randomly recording while riding. This results to long straight lines with a large part of the ride missing.

15

Comentários

58 comentários
  • I have had the same issue for some time now. Am using version 41.0.0 on Android 8.1.0. The whole app seems to stop working midway and continues first after it has been re-opened. I have informed Strava support but they weren't able to fix this yet.

    6
    Ações de comentário Permalink
  • Same issue for me. Strava app is crasching (interrupting any track recording) after not well defined time (from 10 to 30 minutes), It happened after the upgrade to Android Oreo. It is frustrating !

    Nokia N6 with Oreo 8.1. Strava all versions released since a couple of months.

    Does anyone know a workaround or a solution for it

    4
    Ações de comentário Permalink
  • Version 42.0.0 for Android does the same. I'm missing near 10 km from my ride. Is there any fix?

    3
    Ações de comentário Permalink
  • It seems that it has to do with the deep sleep function of Android 7 or higher. In iOS this does not happen, but in android I have monitored it and found that when the device falls into deep sleep, many functions, gps included, get halted. I could disable the deep sleep feature in nougat, but it caused the battery to drain down to 10% after just 4 hours.

    3
    Ações de comentário Permalink
  • I run a OnePlus 5 at OxygenOS 9.0.0 and I successfully fixed it.

    I switched the battery-saving mode off as described in many posts above this one. The issue kept re-occuring.

    So in addition, I locked the app as described in some post above this one. I did a 60 Min run without any issues.

    Although the app was running in the background, meaning when I unlocked my phone I saw it's desktop instead of Strava, the record was complete.

    This was only one run, so I'll keep watching. Also I don't know yet whether it's the combination of locking the app and switching off the battery-saving or just the lock.

    Edit: It's just me checking back after a week of running. Everything's fine with this config. I didn't have any stops of recording. And that's me, coming from having issues in 100% of runs for weeks!!!

    3
    Ações de comentário Permalink
  • I'm having a similar issue. on an hour long ride the time shows 5 minutes and some mileage with long straight lines!

    2
    Ações de comentário Permalink
  • I have same issue. after 15 - 20 min, app stops running!

     

    2
    Ações de comentário Permalink
  • this DOES happen in ios version, too. I was 16 hours into a ride, and it started freezing up. No other apps open, i had to keep touching the screen to keep it alive or it just froze, restarted, and I got the dreaded straight line - which was unfortunate for me, since my ride was basically a 1 mile loop.

    STRAVA - PLEASE FIX THIS. 

    2
    Ações de comentário Permalink
  • The issue is related to all Nokia Phones with Android 8.x.

     

    Here is reported the issue:

    https://community.phones.nokia.com/support/discussions/topics/7000017413

    https://community.phones.nokia.com/support/discussions/topics/7000023855

     Here a workaround:

    https://community.phones.nokia.com/support/discussions/topics/7000022655

     

    Let me know if it is working also for you.

     

    2
    Ações de comentário Permalink
  • Same problem! Huawei P10 Lite - Android 8.0.0. Very frustrating!

    2
    Ações de comentário Permalink
  • for android go to settings > battery > energy saver > strava and UNCHECK the following

    :freeze when in backround

    :automatically optimize when an abnormally is detected

    go back to main screen and  access your gps settings (usually you can long press the gps icon in your shortcut screen)

    set your positioning mode to :device only.

     

    hope this helps

     

    2
    Ações de comentário Permalink
  • Just spotted this great idea a couple of posts above this one.

    I've tried everything else, so going to give it a go. It makes perfect sense to me!

     

    Thanks to Janez Groselj

     

    Try this fix if your strava is crashing

    Press the "running apps" button (usually the left of the three buttons on the bottom of your phone or long-press the menu button if you only have the one) and lock strava app to prevent it from being automatically killed if your phone starts to run low on RAM.

    If your RAM is running low your phone starts to kill running apps and locking an app prevents it from being killed. Strava is quite the memory hog so it's not surprising the phone decides to kill it if it's running out of free RAM.

    You can also find an option in "developer settings" in your phone to change the memory optimization to be less aggressive with killing apps to free up RAM.

    2
    Ações de comentário Permalink
  • I had high hopes that the android upgrade from Oreo to Pie (9.0) on the Nokia 6.1 would solve this issue, but unfortunately that's not the case.

    So kind people at Strava, what are you going to do about this; will you finally offer a solution or should I just look for an alternative service to track rides?

    Kind regards,

    Nigel

    2
    Ações de comentário Permalink
  • Yes, I am experiencing this too.

     

    Tried reinstalling, still faulty. Currently trying beta 44.0.0

    1
    Ações de comentário Permalink
  • I have not solved my issue yet. I have changed my battery settings, system settings etc, however it keeps shotting down between 30 and 45 min. after starting recording. It is a bit frustrating, and I will look for another app if not resolved soon.

    1
    Ações de comentário Permalink
  • Same problem as others. Seems to be fine running but fails during rides. Nokia 6, Android 8.1

    It makes using Strava pointless

    1
    Ações de comentário Permalink
  • I am having the same issue.. I have done some  "investigating" as to what is causing this problem.  

    AND HERE'S what I found... It's nothing the user is doing wrong and nothing wrong with your phone...

    The problem is the stop button is extremely sensitive to touch..

    I road bike and put my phone in a clear plastic pouch... If I for some reason even touch the plastic to hard it pushes against the stop button and you get the dreaded straight red line..

    I also mtn bike with a different pouch, sometimes during a rough ride if the phone jiggles around, the inside of the pouch will touch the stop button and again the dreaded red line..

    I also hike with my phone in my pocket and as the phone moves around it again randomly stops recording as it brushes against my leg ...

    I have suggested to Strava HOW THEY CAN FIX THIS ISSUE... Make the record button an up and down slid similar to a lot of smart phones... I believe up and down would be better than side to side..

    I also suggested they change screen colours when changing a feature.. eg.. when you start to record the screen would have a green bar on top instead of the ever present red... When it goes to auto-pause perhaps a voilet and when you stop the recording it reverts back to Red....

    I haven't heard back from Strava if they are even considering these type of improvements.. But it's nice to know I'm not the only one with the problem...

    HOPEFULLY STRAVA WILL PROVIDE A FUTURE UPDATE WITH some of the listed suggestions...

    1
    Ações de comentário Permalink
  • Strava ran fine on my old phone. Having recently changed to a Huawei Honor 9 Lite with Android 8.0.0, I have had the same problem described by many above where my phone just stops tracking my movement. Searches through the internet gave me this as a possible solution:

    On the phone, go to...

    - Settings 
    - Apps & notifications 
    - Apps 
    - Settings (bottom icon) 
    - Special access 
    - Ignore battery optimisation 
    - Push "Allowed" and select "All apps" 

    - Select "Strava" and mark "Allow"

    I have tried this and it did not provide a solution. I also saw a recommendation to switch off the Display Sleep function which is done:

    Settings
    Display
    Sleep
    Never

    This seems to have worked although I have not tried it enough times to be sure. However, I presume this will make a greater drain on the battery which needs to be avoided.

    I'm not convinced that the suggestion made above that the problem is caused by the sensitivity of the Stop button is correct. In my experience, the recording has just stopped after a short distance cycling. I have my phone in a case and carried in a saddlebag.

    Whatever the cause, it would be welcome if Strava did something about it as it seems to be a significant problem.

    1
    Ações de comentário Permalink
  • Looking into this, I found that it has to do with the deep sleep feature (doze) of the Android 7 and later OSes. When the device goes into deep sleep all software gets halted (frozen) and resumes upon new user activity.

    On 8.1 turning off the battery optimization works fine for me, but on my older Nougat phone that option seems to be ignored.

    1
    Ações de comentário Permalink
  • Did any one get this issue resolved. Happened with my wife's phone then with my phone. Seems to me like the touch screen must never be touched during the recording time. If the phone is in my pocket or bag it stop recording and draw straight lines. If I run with my phone in my hand it's fine.

    0
    Ações de comentário Permalink
  • I have the same issue on my Nokia 6.1 (Android 8.1.0) with Strava v 53.0.1. Strava has never worked on this phone and always crashes half way through a recording. Same thing happens with Runtastic Road Bike Tracker.  Recording on Google Fit works fine though so that's what I have to use currently although I'd much prefer to use Strava 

    0
    Ações de comentário Permalink
  • Has anyone received an update on this?   This is the worst experience.   Rode 40 miles, Strava logs 6 at 49 miles per hour.  WTF...  Come on man..    

     

    STRAVA- PLEASE FIX THIS!!!!

    0
    Ações de comentário Permalink
  • I done a race today.and started recording at the start. Checked a wile later and it only recorded a little section. Started a new recording and it done the same thing. Maybe because the phone was in my left pocket and not the usual right pocket.

    0
    Ações de comentário Permalink
  • Try this and see if it helps.

    On pure Android (e.g., 8.1):

    Settings->Battery->Strava->BatteryOptimisation: not optimised

                                            BackgroundActivity: can run

    Settings->Security&location Location on, high accuracy

    Strava works on my Nexus with Android 8.1. You may want to do the same for Gmail if you aren't getting notified of emails.

    Will check on Nokia 6 2018 Android One 8.1 soon. I think it does concern Android deep sleep/battery saving/memory saving.

    On Xiaomi try this:

    https://www.youtube.com/watch?v=eM_BUlfOAJc

    Or look for similar settings options for your manufacturer-modified Android.

    0
    Ações de comentário Permalink
  • Please add a setting that allows only a user to stop and start Strava (that is, an on an off switch). My experience is that the application randomly decides to shut down.

    0
    Ações de comentário Permalink
  • @Janez Grošelj


    I have recordings problems now for 2 months.

    Like someone said before there is "stop" button problem, I can easly deny that.

    I think I found a solution in relation with battery optimization with gps signal. So, I found in Setting>battery>settings(menu in the right top corner) there you need to turn off everything in relation with anykind of savings.

     

    I will report if it works for some period

     

    Huawei p9

    0
    Ações de comentário Permalink
  • TRY THIS FOR ANDROID, if Strava goes to sleep during your run or records your run as a few straight lines:

    Go to: Settings > Device Maintenance > Battery.  Then set the Power Saving Mode to OFF.

    Good Luck and happy running!

    0
    Ações de comentário Permalink
  • This problem has occurred on many versions of Strava multiple major versions of Android and on multiple phones.In my experience it is related to waking the phone and doing something while recording like snapping a picture. I've tried all of the battery and power options in the above conditions and none of them correct the problem. My only work around is carrying 2 phones. Strava - please investigate. There are a lot of us with this critical problem.

    0
    Ações de comentário Permalink
  • Thanks @Hendrik. I am also running OxygenOS 9 but can't seem to find the exact picks to "lock" an app. Can you please provide the detailed path to that setting/change? Cheers.

    0
    Ações de comentário Permalink
  • The update to Android 9 fixed it for me.

    0
    Ações de comentário Permalink

Por favor, entrar para comentar.

Não encontrou o que estava à procura?

Nova publicação