Samsung Galaxy Watch 46mm - Strava doesn't use gps

I installed Strava last week on my Cubot King Kong 3 phone, that has Android 8.1.0 and works fine. And I was also able to install the Strava app on my Samsung Galaxy Watch 46mm and I got I working.

I installed it on my watch on April 24th and the last activity it recorded was on April 26th. After that date no activity is recorded.

I checked GPS settings on the watch, was active. I did a software reset first trying to fix it. Didn't work. Tried a hard reset. Didn't work. When I start the Strava app on the watch I notice that the gps icon is greyed out, when I start an activity (outdoor walk) it only records time and heartbeat and when I want to save it shows "Strava needs a longer activity to upload. Do you want to discard this one?".

Tested GPS with a gps tool and I saw coordinates. So gps is working.

Any ideas how to fix this. Or is the Strava app for Samsung Galaxy watch buggy?

Regards

Update: It is even getting more strange. I had an activity started on april 30th, outside walk, no gps was there, and no walking time. When I picked my phone this morning I noticed Strava added an activity which was showing the route and time I walked.

 

6

Comentários

30 comentários
  • I had a similar issue to this with my Samsung Galaxy S3 Frontier watch that was paired to my Galaxy S8 phone.  Make sure you don't have any type of power saving mode enabled on your phone.  

    My Strava app was working great on my watch until one day it just stopped recording location.  I couldn't figure out what had changed and my Samsung Health app recorded location just fine on my watch when I went running or cycling.  

    Thats when I noticed I had enabled power mode on my phone.  For some reason that limited Strava's ability to track my location.  Once I took that off Strava started working just fine on my watch again.  

    Not sure if it's the same thing but might be something to check.

    2
    Ações de comentário Permalink
  • Hi Andrew, sorry for the late response. thanks for your suggestion. I disabled power saving on my phone and still it wouldn't work. I removed the strava app from my watch, rebooted the watch and installed it again. Still not working. I repeated this 3 times and finally it started working again.

    But then my phone crashed and i have a Samsung S9 now with Android 9 and strava installed on the phone and watch. It was working great until last weekend. I was riding my bike for about 40km and decided to take a lunch stop so I paused the " Outdoor Ride". After 15 minutes I continued and resumed the ride on the watch. No activity was recorded :-( . I could finish the activity and synced it to my phone but a new activity was not recorded.

    Today I went for a walk and choose "Outdoor walking"  and only the first 150 meters were recorded. I checked the gps status via "Gps status"  and I saw coordinates, so gps is working.

    I will try to disable power saving on this phone and hope that it will start working again.

    regards

    1
    Ações de comentário Permalink
  • Hi Marcel, have you found the solution for this? I have exactly the same problem, GPS icon still greyed out, its not recording activity.

    0
    Ações de comentário Permalink
  • Fixed my problem by re installing app on the watch, gave it all the permissions when it prompted after install, and went to settings on the phone and gave the phone app also all permissions. Hope this will help you

    0
    Ações de comentário Permalink
  • I have a similar problem: I start outdoor run within the Strava app on my Samsung Galaxy Watch Active and it only tracks time and heart rate but no pace or miles... 
    Reinstalling didn't work and also power saving mode is turned off on my phone (Huawei P20). I don't have any more ideas how to fix this and it is super annoying since I cannot use it for running anymore :-(

    2
    Ações de comentário Permalink
  • Same problem here. It recorded one session, and everything after that gets discarded because it does not record the distance i ride. I have Huawei P20 Pro and Samsung Galaxy S3. Tried to reinstall the app on the watch with no luck. 

    1
    Ações de comentário Permalink
  • i have the same problem. Does Strava have any solution for this?

    1
    Ações de comentário Permalink
  • I have the same problem but find that GPS does start working after about 20 mins.
    Definately a bug in the strava App as Samsung Health picks up gps in a matter of seconds

    1
    Ações de comentário Permalink
  • GPS also isn't work with the Strava app for me. Anyone got a solution? Would be nice to hear from Strava on the issue

    1
    Ações de comentário Permalink
  • I have the same problem. Will anyone from support provide some solution? Any updates?

    0
    Ações de comentário Permalink
  • Hi all, Until now i don't have any issues with Strava on my samsung watch. To get it running it unistalled it via the Samsung Gear software, did a factory reset of the watch and installed it again. No problem since.

    The only time Strava in not working well is when you are in a forest.

    Good luck..

    Regards

    1
    Ações de comentário Permalink
  • I just did a factory reset and reinstalled the strava app....

    it took 4 seconds to get GPS signal

     

    Just a pain that i now need to setup and install all my watch faces all over again

    1
    Ações de comentário Permalink
  • I have the same issue with Galaxy Watch and Samsung Galaxy S8.

    The GPS icon on the Strava app on the watch is greyed out and no distance is recorded during outdoor activity. 

    The strange thing is that it was working fine until some weeks ago...

    0
    Ações de comentário Permalink
  • I was able to fix mine by going to the Galaxy Watch settings

    swipe down the watch screen
    > gear icon
    > connections
    > Location On 
    and choose a method if GPS and/or wireless network

    0
    Ações de comentário Permalink
  • I have the same problem! The GPS icon is grey and it doesn't search for a signal. I have no problem with my gear tracker app, though

    0
    Ações de comentário Permalink
  • I figured it out on how to solve my case.

    The GPS icon was always greyed out. I don't know if all these steps are necessary but they solved it:

    1 - uninstall Strava on phone and galaxy watch

    2 - install Strava on phone and galaxy watch

    3 - On the phone, manually start a running activity. It will ask you to allow Strava to use GPS. Certify that you allow it.

    Done!

    I did 1 and 2 and Strava was still not able to use GPS. Doing step 3 solved it and now, in a matter of 1 or 2 seconds, the GPS icon becomes active.

    1
    Ações de comentário Permalink
  • Diogo's fix worked for me. Many thanks.
    I just did your step 3, not necessary to uninstall & reinstall.
    After the fix, the GPS in Strava app in the watch was active in 2 seconds ;-)

    0
    Ações de comentário Permalink
  • I tried Diogos but it has not worked for me :( did you just start the activity normally on your phone?

    0
    Ações de comentário Permalink
  • Sophie, yes. Just pressed the plus button, to start monitoring a new running activity, on the Strava app on the phone and immediately asked me to allow access to GPS.

    0
    Ações de comentário Permalink
  • I have the same problem. Strava App doesn´t get the GPS signal in some cases.

    I found the reason:

    1. It works, when I deactivate bluetooth on my smartphone and after that I leave the house.

    2. It doesn´t work, when the bluetooth connection between watch and phone is active and after that I leave the house.

    Maybe the watch is trying to get the GPS location via the phone(via bluetooth) in case the watch is not able to get the GPS signal from the GPS sensor in the watch(because I am within the house) and I guess when I leave the house without phone then the fallback from phone GPS location to the watch GPS location is not working properly.(especially when the phone is also not able to reach GPS signal)

    Please try to deactivate bluetooth on your phone before starting strava app and starting a new running activity and share your results here. Maybe someone can confirm my theory.

    0
    Ações de comentário Permalink
  • My issue is that the S3 locks onto GPS, but when I start the activity (like running) the timer will start but it won’t record data nor will it give me my pace which it has in the past.  Auto pause won’t activate either which is how think that it’s not locked onto GPS even thoug the GPS/location icon is ‘solid’

    I’ve

    -reset watch

    -delete and download app again

    Still does not work.  Frustrating!

     

     

    0
    Ações de comentário Permalink
  • Unfortunately this does not work for me... running out of ideas!

    0
    Ações de comentário Permalink
  • This is ridiculous. I cant use my samsung active watch with strava. The gps doesnt work. Its working fine on the watch with samsung health but in strava it just dont connect. Are you going to fix this problem, Strava? I have tried all of the above with no long term result. Any updates soon?

    3
    Ações de comentário Permalink
  • Same here. It's really frustrating, especially since (unlike with Nike Running Club) it's impossible to edit the run so either I lose all the data and put in the correct distance or I keep saving incorrect runs.

    Strava, please do something about it!

    1
    Ações de comentário Permalink
  • +1 This is ridiculous, and I hope we get support for it quick. I have the same issue with a galaxy watch 46mm

    1
    Ações de comentário Permalink
  • I managed to fix it by uninstalling Strava on my phone and then doing a complete re-boot of my watch. I then re-installed Strava on both my phone and watch and started runs on both separately to approve privacy settings. This seems to have worked!! I am worried about changing too many settings on my watch though in case it stops working again.

    0
    Ações de comentário Permalink
  • The same porblem here with my Samsung Gear Sport Watch. No gps signal seems to be acquired at any point.

    Already did some of the abobe, but still the same.

    0
    Ações de comentário Permalink
  • FIXED.

     I was having the same issue, with no tracking having a Greyed out GPS icon.

    Try turning the APP Permissions on and off again:

    • watch Settings (cog icon)
    • scroll down to (Apps)
    • scroll down to (Permissions)
    • Find Strava App
    • Cycle off then back on (Location).

    when going back into the Strava App the Greyed out GPS icon turns white after approx 5 -10 seconds.

     

     

    0
    Ações de comentário Permalink
  • Fixed (at least for now)!

    1) I made reset on watch.

    2) I re-installed the strava app on my phone.

    3) I installed strava app on my watch

    4) I gave permission for the location use

    And then everything is ok again.

    I hope I won't face ths problem again. Last time it failed me during an important race.

    I should have bought a garmin... :/

     

    0
    Ações de comentário Permalink
  • Hey Guys,

    I have a Gear S3 Frontier and as a commenter mentioned above, put your watch into airplane mode, meaning no Bluetooth either. When you launch the Strava app, it should go from grayed out to white in about 10 seconds. 

    Also, another note for more accurate runs with your Gear S3 in stand-alone mode (no phone connected) set your GPS to "high accuracy mode." This will burn through the battery faster but is significantly more accurate. 

    -To enable high accuracy mode, go into S-Health App/Record Your Workout/Workout. 

    -Next to running/walking there is a gear icon. Tap it and then scroll down to Location and select it.  

    -Under location (which should be enabled) there is a switch for High accuracy which you'll enable. 

    From my experience using the both the native S-Health tracker and Strava, it looks like these apps on the gear prioritize using your phone's GPS and network connection so you essentially have to force it to rely solely on the internal GPS of the watch by completely disabling all connections. 

    I hope this helps! 

    Cheers, 

    Paul 

    0
    Ações de comentário Permalink

Por favor, entrar para comentar.

Não encontrou o que estava à procura?

Nova publicação