Samsung Galaxy Watch 46mm - Strava doesn't use gps

I installed Strava last week on my Cubot King Kong 3 phone, that has Android 8.1.0 and works fine. And I was also able to install the Strava app on my Samsung Galaxy Watch 46mm and I got I working.

I installed it on my watch on April 24th and the last activity it recorded was on April 26th. After that date no activity is recorded.

I checked GPS settings on the watch, was active. I did a software reset first trying to fix it. Didn't work. Tried a hard reset. Didn't work. When I start the Strava app on the watch I notice that the gps icon is greyed out, when I start an activity (outdoor walk) it only records time and heartbeat and when I want to save it shows "Strava needs a longer activity to upload. Do you want to discard this one?".

Tested GPS with a gps tool and I saw coordinates. So gps is working.

Any ideas how to fix this. Or is the Strava app for Samsung Galaxy watch buggy?

Regards

Update: It is even getting more strange. I had an activity started on april 30th, outside walk, no gps was there, and no walking time. When I picked my phone this morning I noticed Strava added an activity which was showing the route and time I walked.

 

8

Comentários

34 comentários
  • I recently bought a Samsung galaxy watch & I was facing the same issue. 

    As a workaround, I switched off the Bluetooth on my phone before starting the Strava activity on my galaxy watch. With this, I have no problem in recording the session using the watch's GPS.

    Post workout I can launch the strava on my phone & sync the data manually.

    0
    Ações de comentário Permalink
  • Hi Guys,

     S-Health is a little bit annoying when one uses another tracking apps. Try to disable It, Strava apps will work better. You can also try the Run4Gear app it is also compatible with Strava. It may solve your problem.

    Have nice run, Galaxy Watch is great for running

    0
    Ações de comentário Permalink
  • Hi guys, I found a solution by luck. Last sunday, I had a competition and when I tried to use Strava in my Samsung Galaxy Watch Active, the GPS didn't work (I wasn't with my phone - Samsumg S10+). Since the race had already begun, I opened S-Health and started an activity there (with Strava still working). After the run (I stopped the activity in S-Heath), I checked Strava in the watch and was still working. Surprisingly, all the GPS data was there. I don't know how, but Strava worked thanks to S-Health.

    I hope this help

    0
    Ações de comentário Permalink
  • Bernhard's solution worked straight away, deactivate the bluetooth on your smartphone, open the strava app on your smartwatch and withing secs the GPS signal will become active.

    Thanks

    Tasos

    0
    Ações de comentário Permalink

Por favor, entrar para comentar.

Não encontrou o que estava à procura?

Nova publicação