С ответом

Can the Apple Watch 2 have a GPS signal strength indicator?

It would be really helpful to have an icon on the Apple Watch 2 Strava App to confirm that GPS signal has been acquired by the watch before commencing a run. I have noticed a number of runs when the watch starts recording data 2-3 minutes after actually starting the activity. There seems to be no way of confirming that the GPS is receiving prior to the activity - the only indication is that the device does not log distance. I note in the following on the Apple Watch Series 2 Support page:
"You will be prompted to accept location, Health permissions, legal disclaimer and notifications 
Wait to acquire GPS signal and hit start"



Комментариев: 32
  • Официальный комментарий

    There’s a known Apple bug where if you start the recording near your phone and then head away to start your activity, a few points get recorded into the file (pulled from the Phone’s GPS) and the activity distance is initially being measured from those phone GPS points.

    When the watch goes outside and the phone stays at home, it takes the watch a long time to start getting its own location. This causes a large gap in the GPS data and due to this the first set of GPS points are ignored when the activity is saved and data is analyzed.

    We’ve recently made changes to try and fix how the data is interpreted on our end. Please let us know if you are still missing the starting section of your runs.

  • I agree. How are we supposed to ascertain that GPS signal has been acquired when using the Apple Watch 2 app?

    Perhaps the start button could change colour? Maybe an icon appears? Haptic/Audio feedback? While I'm on about it, some indication of intervals being reached would be a nice touch, although I'd argue it should be expected. Strava is lagging behind competitors here.

  • I am unable to even start my run. The orange button is there but it does not start. I've tried everything I can think of to fix the issue but nothing works. Please help! I haven't even gotten as far as prompting to accept location, Health permissions, etc"


  • I'm having the same problem as Melissa above. Tow days now I've tried going for a run with Apple Watch 2 and I stand there hitting the start button repeatedly, waiting for the stupid app to start and it never does. Then I just switch over to the running app from Apple and it starts right away. I tried turning off my phones Bluetooth so it wouldn't interfere but ya, still won't start a run or a bike.

  • I do have the same problem as Melissa Roy now (unable to even start my run. The orange button is there but it does not start). I've already been able to use it in the past but no more now. Is this a known issue? Please help. Thanks

  • Strava will not start on Apple Watch 2. Press orange start button and nothing happens.

  • For those who can't get the start button to work I found this on the Strava support FAQs:

    The start button no longer works

    Navigate to Settings on your iPhone and select Privacy > Motion & Fitness. Make sure Strava is turned ON so the toggle is highlighted green.You may have to uninstall and reinstall the Strava app before doing so. While in the Privacy section of your Settings, make sure Location services and Health are enabled.

  • Thanks Brady. It helped me to start the Strava App on my Apple Watch 2.

    Do you know how to cancel a run or a ride. It seems that the only options are Pause & Start.


  • Nice to know I am not the only one with this problem.  I hope this gets fixed soon.

  • I have just recently purchased an Apple watch 2. First run I carried my iphone7 along with the apple watch and logged the run with starva on both devices. The iphone showed I had ran 10.3km but the watch only 9.6km. I have confidence in the accuracy of the phone as I have used it when running in competitions and it always is spot on. I went on another run, this time only using the watch just to make sure there was no conflict but again the same run was logged as 9.6km! I bought the watch specifically to monoitor how I was running but it seems its not going to be of any use and I will have to continue using my phone if  i wish to continue with strava. Anyone else unhappy with the distances being logged?

  • The GPS connection delay is killing me on Apple Watch 2 without iPhone. Not starting until at least half a mile into my run. Please fix!

  • I have the same problem with the gps signal, i had a few runs where the first minutes where not recorded! Good idea to have the signal confirmed before you start. 

  • I've just submiited a support ticket because of this.  The app doesnt start tracking until a km or more into the run.  Definately need a GPS signal confirmation on screen like Garmin have.

  • Ditto, another one with the same very annoying issue! Did a 10k Saturday that missed the first 2k off! Please fix strava

  • Same here, always missing the GPS connection for the first 2-3min. Please make a indicator on the screen. Like this not a useful app.....

  • Same problem. Adding comment in the hope not to miss news of a fix!

  • I have the same problem. Also when the runs pairs to my iPhone it read a different distance than what the splits show. example data transferred to iPhone reads 8.3 miles but splits state 8.7 miles. actual run closer to 9. compared to other GPS devices that were present.

  • Interesting to read the comments here. In recent runs my AW2 only recorded 4.4km for a 5k Parkrun and then for another Parkrun course only ever gets to 4.9k, I know that course is more like 5.1k. Seems to takes time for the AW2 Strava App to acquire a signal, struggles with trees and I noted pauses when you turn your wrist to look at current progress. Could be the AW2 Hardware at fault, but no such issues with the standard Activity App or Nike + App, so I think more work needed please Strava. 

  • Same problem here with delayed gps signal misreporting pace numbers at completion on iPhone app. Nike plus never had this issue. Need gps indicator or use whatever method Nike and default workout app use to accurately gather info before gps acquired. Thanks.

  • Same issue. Went for a mile PR, and realized a half a mile in that it was counting time but not distance for the first third of a mile or so. I just gave up.

  • Having the same problem. Missed about the first mile of my last two runs. Very frustrating.

  • I'm having the same issue.  On top of not acquiring signal for the first .5 mile or so, once the run gets uploaded, the overall pace Strava reports is way off.  Essentially, it counts the distance run without GPS signal, but doesn't count that time and reports a much lower overall pace than in reality.  

  • Hi Scott, Mike, Eric and others. The new iOS 11 update means you can use the standard activity app on the AW2 for your run and extract the GPS data out of Apple Health with an App like RunGap and therefore to Strava etc.

    This means actually no need for the Strava AW app at all! I find the activity app much better at acquiring GPS and general accuracy. I tested last night and it worked well. Strava app deleted from my AW until some serious improvements are made..

  • Dave, THANK YOU!  I was under the impression that even with iOS 11, there was no way to export runs from the Workout app to Strava, or anywhere for that matter, and am very happy to find out that's not the case.  It costs $1.99 for 3 months to be able to do it through RunGap, but well worth it, especially now that the Health app now calculates VO2 Max.  This is awesome, thanks again.

  • Wow, I'm impressed that you found this workaround. It really goes to show that Strava has got to improve the app though---it's not a hardware problem.

  • Ugh, actually, now I've noticed that when I export from Workout app to Strava, I'm losing around 5% of the overall distance.  Pretty similar when I export to RunKeeper, too.  Exporting to Garmin, though, works perfectly.

  • Elle,

    I'm using the AW3 and can confirm that something is still a miss here. The on the fly queues per km sounded right during the run, however upon the watch syncing with the phone when I got back, the report is a little strange.

    It appears that the total distance is actually correct (compared to previous runs when the phone itself was taken on the run) though both the map and pace indicator are way off (similar to what Eric reported above).

    All this exporting and importing business is a bit of overkill, personally, in the age of "things just work"...

  • @Ash I’ve been using the iSmoothRun App for the last few months. This shows GPS strength on the watch if using the watch or phone GPS. It then auto posts to Strava when completing an activity. I’d really recommend it.

  • For the past several runs, using the Strava App for Apple Watch S2, the first 1 or 2 minutes of the run are missing. The total distance is correct, but the route I ran is missing in the view on Strava.com.

    This is happening almost about 50% of my runs now, for example, my past 6 runs - half are missing data at the beginning, mostly the same amount of delay each time.

    Missing beginning of run:
    1. https://www.strava.com/activities/1618822434

    Not missing beginning of run:
    2. https://www.strava.com/activities/1600198011

    Missing beginning of run:
    3. https://www.strava.com/activities/1585464595
    4. https://www.strava.com/activities/1582581305

    Not missing beginning of run:
    5. https://www.strava.com/activities/1574866415

    Not missing beginning of run:

    6. https://www.strava.com/activities/1567316372

    I am not anywhere near my phone when I start the Strava App. I bring up the Strava App after I am 2 blocks away from my phone, which is back at hime.

    The total distance run appears correct, but my route is missing from the map.

    One other strange things is that, every time, the Strava App starts a run, then pauses, then starts again. It auto pauses unnecessarily at the beginning of EVERY run. To combat this, I tried keeping the Strava App active when starting my run, but it still always auto pauses for now reason as I start running.


  • Jono, I'm getting exactly the same with the random missing beginning of run and auto pause at the start. Have you found any way around it?

Войдите в службу, чтобы оставить комментарий.

Не нашли то, что искали?

Новая публикация