No Heart Rate in Strava App on Galaxy Watch

Hi,

just started using Strava on my Galaxy watch and GPS tracking is pretty good and upload is quick at the end of my run, however, i can seem to get any heart rate data in my session, i know the HR sesnor is working because it work when not using the App.

Is there a setting somewhere to enable this or do I have to enable summit in the app to get the data or is it the app cannot access the HR sensor on my watch?

 

5

Комментарии

Комментариев: 19
  • I have the same issue. Using a Galaxy Watch with various settings for built-in watch HRM: always on, frequent, or none. It doesn't matter what watch setting. After a Strava session, heart rate either doesn't get measured at all, or gets pinned at some high rate after a brief time of tracking.

    2
    Действия с комментариями Постоянная ссылка
  • Hi James & Paul, 

    It sounds like it'd be better to help you out through a ticket so we can troubleshoot what's happening. Please feel free to write to our team

    0
    Действия с комментариями Постоянная ссылка
  • Does anyone have a solution to the missing heart rate monitoring when using strava on galaxy watch?

    0
    Действия с комментариями Постоянная ссылка
  • Hi Morten,

    I have not been able to figure out why, the only work around I have managed to get a reading is to ware the watch so that the sensor is on the under side of your wrist, it's a bit uncomfortable but I find the tracking poor so I am at the point tof giving up with it. Be good to hear if they fix it, I suspect it's a Samsung problem.rather than strava but then again endomondo seem to work ok

    0
    Действия с комментариями Постоянная ссылка
  • Having same trouble with heart rate monitor on Galaxy watch when recording ride on Strava. - Seemed to work for the first ride, Next ride showed odd readings all high. Last couple of rides no heart rate recorded at all. Does anyone know if Issue with Samsung or Strava? Thanks.

    1
    Действия с комментариями Постоянная ссылка
  • I'm having the same issue. No matter how you configure it, I cant have a reading. I believe it's a primary problem of the app, since the native samsung activity tracker show the heart rate properly

    1
    Действия с комментариями Постоянная ссылка
  • Currently having the same issue.

    First thing to check is the 'Data permissions' in the Strava App, it will not send HR data if this is not enabled. Now it seems to work with indoor activities. 

    But still it doesn't send any HR data if I use it for outdoor runs.

    Don't know yet if these issues occur random..

     

     

    0
    Действия с комментариями Постоянная ссылка
  • Nick V., I wonder if that is because the outdoor activities also require GPS?  Maybe it will only gather data from one sensor at a time?  I dunno... it's weird.

    Mike C.

    0
    Действия с комментариями Постоянная ссылка
  • Currently it seems to submit the HR data to Strava. So it looks like a random problem.

    This make the application feel very unstable, also had some problems with syncing (ending up with 10+ added activities + notifications to all my Strava-friends).

     

     

    0
    Действия с комментариями Постоянная ссылка
  • Currently stopped using the watch to record rides as not reliable enough. Phone has always worked well enough. Only used the watch as it was supposed to record heart rate which I thought would be cool ...until it proved to be too unreliable. Will try again in the summer and maybe some software updates may have improved it by then? 

    0
    Действия с комментариями Постоянная ссылка
  • My S3 watch detects ok, but maxes out at 10-15 bpm below Samsung Health and mapmyrun apps at same level of effort.

    0
    Действия с комментариями Постоянная ссылка
  • Hello, Has anyone had a response/resolution from Strava on this? I am finding when on an outdoor cycle the strava app has long periods where the heart rate is not being recorded. Grateful for advice on how to address this. Thanks.

    1
    Действия с комментариями Постоянная ссылка
  • Mine records the first kilometer or so when walking, and then it just produces a flat line thereafter (at max HR). Tried logging 3 sessions yesterday with the same result. Will try to tighten the strap and test on the bike tonight.

    0
    Действия с комментариями Постоянная ссылка
  • Currently - Disabled the e-mail and phone capabilities of the watch and Strava has been working fine for last 4 or 5 rides, including heart rate. I Take my phone with me anyway so decided that I could just use the watch for recording rides only. The watch battery also last longer this way 3-4 hour ride and only used 30%.

    0
    Действия с комментариями Постоянная ссылка
  • I had the same issue and got it FIXED doing this:

    Go onto the Strava application on your phone and go into "Data Permissions" and select Health-Related Data -> Access Allowed.

    I then de-installed and re-installed the Strava app on my watch (not sure if this step is necessary).

    And now my heart rate is included in my run analysis (I don't have the Summit Version)

    6
    Действия с комментариями Постоянная ссылка
  • I have a Samsung gearfit 2 watch and I have the same problem....no heart monitoring, works great via the Samsung health app so it definitely works

    The majority of my friends on strava do not use android and theirs work perfectly, very frustrating

    0
    Действия с комментариями Постоянная ссылка
  • Galaxy watch 42. It still does not register heart rate and it is very frustrating when I am with Summit..

    It seems like many people have this problem.

    Will you please talk to samsung about this problem, Strava? It would be very nice. 

    ----------------------------------------------------

    Update

    As some other people also mentioned, I also fixed it by allow data permission in Strava app. 

    0
    Действия с комментариями Постоянная ссылка
  • "Go onto the Strava application on your phone and go into "Data Permissions" and select Health-Related Data -> Access Allowed."

     

    What if this setting is not in that menu? 

    0
    Действия с комментариями Постоянная ссылка
  • Hi Jim - I opened the app, opened my profile, went to the settings  and Data Permissions was there. Hope you find it as well.

    0
    Действия с комментариями Постоянная ссылка

Войдите в службу, чтобы оставить комментарий.

Не нашли то, что искали?

Новая публикация