Unable to Authorise Strava on Fitbit

I have a Fitbit Versa and have just set up a Strava acount. I have authorized strava through strava.fitbit.com. However when I try to authorize from fitbit app I am unable to.

I have checked all setting /permissions as confirmed that internet is connected there. Whenever I try to authorize, it takes me to strava.com. After I log into Strava its points to the below url then kicks me back to the original authorization screen.  I am also contacting fitbit and have had several friends (all Strava / fitbit users) who have checked and can't get it to work for me either.



Kind regards




  • I too have had this problem since installing Strava. It worked for a day or two then unauthorized itself. Very frustrating. Considering paying for the full Strava experience but not keen when this is an ongoing issue. Fitbit says it is a Strava update issue.

  • same problem here, any help is welcome

  • Same here

  • Same here

  • I've got the same problem too. I've just started using Strava but might uninstall it as I track my runs using my Fitbit Versa 😕

  • Was a solution ever reached for this? I am having exactly the same problem. Syncing was working absolute fine (and has been for 18months or so) - worked fine one day and then just stopped - have all the lasted updates etc and have resinstalled and rest everything and still this is happening and I cannot authorise the account. So frustrating, any help would be appreciated....

  • No, never resolved. Though it synced yesterday strangely. After having not worked since March.