Strava beacon not working

The beacon is not working. I only purchased the premium version for the beacon feature and it has not been working for the past couple months. My activity records fine. However, when my partner clicks the beacon link I sent to her, it just says that my activity has not started. I followed the troubleshooting advice already on the forum. Still no dice. This is very disappointing.



  • Same here ... I cannot enjoy my rides knowing that my girlfriend is in worries not having any clue where I am ... :(

  • Any update on this? My wife keeps saying that she gets a message saying, "We haven't seen any recent data from this athlete. Their phone may have lost connection or its battery may have died"  when she clicks the link.  I don't know why?  This happens when I know my phone is at almost 100% battery and I haven't lost any connection.  What gives?


  • Same problem here. No explanation from strava either. Has anyone managed to get theirs working again after this isssue popped up?

  • So, my phone did an OS update (Android) and after that, I noticed I was logged out of Strava.  I logged back in and it seems to be working now.  I am not sure if Strava did an update or not, but now many times after my run, I have to log into Strava again.  I don't know why it isn't staying logged in, but at least my wife is happy she can track my runs.  Just a minor inconvenience.  

  • Solution I found (Android phone - Galaxy A8):

    1. Uninstall Strava application

    2. Reinstall Strava application

    3. Go into Parameters : Application > Strava

       I noticed there that there was not authorization for GPS, phone or file access. So I enabled everything / gave authorization to all required services.

    A quick test showed that Beacon is now working again.

  • @David F

    Having the same issue, with my Garmin watch saying LiveTrack was started and a Beacon was sent, but my wife doesn't receive the text. Tried it a bunch of times last night as tests. Did the uninstall - reinstall, location is authorized, still no dice, Beacon still not working.

    This is one of the main reasons I'm paying for Strava Premium.

  • My garmin edge 1000 says livetrack started when I start a ride, even though beacon and livetrack toggled in ‘on’ positions in garmin connect app. Beacon text no longer sends to my safety contact no matter what I have tried in settings, uninstall both strava and garmin connect, reinstall.
    Garmin connect does not save livetrack and beacon settings when I back out of the settings page.
    This happened starting last week after garmin connect app update 4.18

  • My Garmin edge 1000 says livetrack started when I start a ride, even though beacon and livetrack toggled in ‘on’ positions in Garmin connect app. Beacon text no longer sends to my safety contact no matter what I have tried in settings, uninstall both Strave and Garmin connect, reinstall.

    This started May 11 and I have not been able to fix and have had to resort to using email notifications which are not as convenient.

    This is the only reason I purchased Summit so how do you fix?

  • I have the same issue as Christa.  Gamin Connect won't save the settings on the Livetrack page.  When you back out and return, Strava beacon is turned off.  So frustrating.

  • I’m having the same issue with Strava/Garmin livetrack after the last Garmin update. Please correct!

  • The worst part is that Garmin created a ticket for the issue, asked if they could have access to my garmin connect account, requested a zip/compressed file from me which I sent to them, and their only reply was that it could take weeks to months to fix and not to expect a fix anytime soon. BUT ty for being a garmin customer! Just Horrible follow through! Meanwhile I am paying for strava summit and the beacon does not work because the toggle for the beacon in the garmin connect app does not trigger a text, even when it’s in the ‘on’ position each time.
    Btw strava consent is on the whole time in the garmin connec app.
    Is it possibly an issue with stravas consenting with garmin when the app updated? Maybe the issue is on strava’s end. Can someone from strava please answer us paying summit customers who are NOT getting what we paid for?!

  • Just want to add my voice to the chorus. Mine has not been working for about the last month as well (I have a Galaxy S8+). I'll try the uninstall/reinstall but, according to most of the posts above, it's probably not going to solve the problem. And, like most folks above, this is one of the main benefits of Premium for which I'm paying, and the lack of ability to keep my wife informed about where I am is a major pain (and yes, I know you can use other tools like Google Share or Glympse, but having to launch a second app with a separate process is not the idea).

  • Just a follow-up. The uninstall/reinstall, reestablish the contact, and restart the phone worked for mine. Glad that wasn't all futile as it was for several others. I hope Strava addresses this so searching for a fix is not required.

  • So I contacted strava over the same issues, they told me it was a Garmin Connect problem and the latest update should solve it, but it hasn’t, my wife now eventually gets a text, but it’s says I have not started my run...(I cycle and do not run), I will try Garmin and see what they have to say, it’s getting frustrating now as I have tried all possible solutions and nothing works.

  • WTF!!!

    Get this fixed! It’s why we pay! So annoying.

  • Same issue as many others; Garmin Connect starts the LiveTrack, and Strava notifies me the beacon has been started. But my wife never gets the text. Very annoying (this is after all the recent updates, restarting everything, and checking all permissions).

  • When I start a ride I launch from my garmin 1030 and my family receives the text from strava but they can never get it to open.

    Strava - These issues go back over a year and you haven’t addressed the problem or even mentioned you’re working on a solution. What is the deal?

  • Hi guys, the only way I have worked around this is I start my 1030 as normal but I also have to record my ride on the strava app on my I phone, this allows me to send a text to my wife and the tracking works, not ideal obviously as it drains the phone battery but it’s the only solution that works for me currently, but Garmin and Strava seem clueless why there is a problem with live track.

  • I had the same issues the rest of you guys.

    I was running Strava through the app on Samsung S7.

    I also tested on an old Samsung S5 when the issue occurred.

    Same problem on both phones.

    Not running with any Garmin stuff (So maybe Garmin are not the issue ?)

    I uninstalled the app and re-installed on the S7 and it now seems to be working fine.

    Hopefully this helps someone somewhere trace their problem !!


  • I had the same issue and one of the posts above triggered me to try to log out and log on again on my phone. Could not find the log out option, but there was one thing in the settings that was remarkable. It said in the app settings that I had a free account, while I have a paid account for years now. I do not know what I did but at one moment it suddenly showed I was a Summit member. Now the beacon seems to be working again.

    So check you account settings in the app.

  • Same here. Seems logging out and back in fixed the issue. My membership status was also stated as "Free" instead of "Yearly subscription".

    You can log out on the very buttom of the settings section. I think this may have occurred because I used google sync to "copy" all my apps to a new phone. As far as I remember I didn't need to log in at Strava on the new phone after this sync.

  • This post from Benjamin fixed it for me.

  • Been having same issues... Have experienced both no beacon being sent and beacon being sent, but no data being received.  Very frustrating.  Just tried the above log out and back in, not very hopeful tho.  My subscription/profile was listed as yearly? And it says same now after logging back in. It sure would be nice to hear from garmin or Strava on this issue.

  • Thanks Benjamin. You are the man.

  • Benjamin's solution worked for me as well. I let my full summit pack expire before purchasing the safety pack on a monthly basis. Seems the app didn't update so I logged out and back in, works fine now. 

  • Had the same problem. After reading suggestions here tried simply logging out then back in again, then switching on the beacon feature. This seems to have sorted the problem, though a shame that the Strava team can't post a solution.