Samsung Galaxy Watch 46mm - Strava doesn't use gps

I installed Strava last week on my Cubot King Kong 3 phone, that has Android 8.1.0 and works fine. And I was also able to install the Strava app on my Samsung Galaxy Watch 46mm and I got I working.

I installed it on my watch on April 24th and the last activity it recorded was on April 26th. After that date no activity is recorded.

I checked GPS settings on the watch, was active. I did a software reset first trying to fix it. Didn't work. Tried a hard reset. Didn't work. When I start the Strava app on the watch I notice that the gps icon is greyed out, when I start an activity (outdoor walk) it only records time and heartbeat and when I want to save it shows "Strava needs a longer activity to upload. Do you want to discard this one?".

Tested GPS with a gps tool and I saw coordinates. So gps is working.

Any ideas how to fix this. Or is the Strava app for Samsung Galaxy watch buggy?


Update: It is even getting more strange. I had an activity started on april 30th, outside walk, no gps was there, and no walking time. When I picked my phone this morning I noticed Strava added an activity which was showing the route and time I walked.




  • I had a similar issue to this with my Samsung Galaxy S3 Frontier watch that was paired to my Galaxy S8 phone.  Make sure you don't have any type of power saving mode enabled on your phone.  

    My Strava app was working great on my watch until one day it just stopped recording location.  I couldn't figure out what had changed and my Samsung Health app recorded location just fine on my watch when I went running or cycling.  

    Thats when I noticed I had enabled power mode on my phone.  For some reason that limited Strava's ability to track my location.  Once I took that off Strava started working just fine on my watch again.  

    Not sure if it's the same thing but might be something to check.

  • Hi Andrew, sorry for the late response. thanks for your suggestion. I disabled power saving on my phone and still it wouldn't work. I removed the strava app from my watch, rebooted the watch and installed it again. Still not working. I repeated this 3 times and finally it started working again.

    But then my phone crashed and i have a Samsung S9 now with Android 9 and strava installed on the phone and watch. It was working great until last weekend. I was riding my bike for about 40km and decided to take a lunch stop so I paused the " Outdoor Ride". After 15 minutes I continued and resumed the ride on the watch. No activity was recorded :-( . I could finish the activity and synced it to my phone but a new activity was not recorded.

    Today I went for a walk and choose "Outdoor walking"  and only the first 150 meters were recorded. I checked the gps status via "Gps status"  and I saw coordinates, so gps is working.

    I will try to disable power saving on this phone and hope that it will start working again.


  • Hi Marcel, have you found the solution for this? I have exactly the same problem, GPS icon still greyed out, its not recording activity.

  • Fixed my problem by re installing app on the watch, gave it all the permissions when it prompted after install, and went to settings on the phone and gave the phone app also all permissions. Hope this will help you